Bug 86084 - sendmail SRPM for 8.12.8 patch and spec file mismatch
Summary: sendmail SRPM for 8.12.8 patch and spec file mismatch
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-13 17:58 UTC by Aaron Sherman
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-26 09:50:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aaron Sherman 2003-03-13 17:58:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
The spec file for Red Hat 8.0's most recent sendmail errata update (8.12.8-1.80)
has support, via the "%errata" define, for other Red Hat Linux releases
including 7.3. However, due to hard-coding of DB versions in one of the patches,
this support is broken (e.g. prerequisites all match, but build fails). I'm
thrilled that Red Hat had the foresight to realize that many of their customers
who cannot upgrade wholesale to 8.0 would need a sendmail upgrade, but to ship
it with these helpful changes in a broken state is rather unfortunate.

I got this SRPM to build easily enough by altering the
"SOURCES/sendmail-8.12.2-redhat.patch" file from the SRPM.

After doing an "rpm -i". I changed "-ldb-4.0" (which seems to be a bad usage for
a whole lot of reasons) to "-ldb", which should work just fine given that both
RH7.3 and RH8.0 will create a "libdb.so" which points to the appropriate version.

Now, simply changing "%errata" to "73" results in a clean build that installs
without a hitch. I'm now running it with TLS turned on and I'm a happy camper,
but perhaps other Red Hat users would benefit from another update which fixes
the 8.0 SRPM so that it can build under 7.x?


Version-Release number of selected component (if applicable):
sendmail-8.12.8-1

How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.
    

Actual Results:  see above

Expected Results:  see above

Additional info:

see above

Comment 1 Florian La Roche 2003-03-26 09:50:14 UTC
http://people.redhat.com/laroche/ has a new src.rpm which has this fixed.

greetings,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.