Bug 860855 - The latest kernels fail to boot from SDCard on OMAP and Tegra
Summary: The latest kernels fail to boot from SDCard on OMAP and Tegra
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 18
Hardware: arm
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2012-09-26 21:21 UTC by D. Marlin
Modified: 2012-10-17 12:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 12:29:11 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for omap and tegra configs to enable MMC support (built-in) (1.10 KB, patch)
2012-09-26 21:21 UTC, D. Marlin
no flags Details | Diff

Description D. Marlin 2012-09-26 21:21:52 UTC
Created attachment 617790 [details]
patch for omap and tegra configs to enable MMC support (built-in)

Description of problem:

The latest kernels (3.6.x) fail to boot from SDCard on Panda (OMAP) and Trim Slice (Tegra).  The F17 kernels would boot from SDCard, so this appears to be a regression.  The issue is a change in the kernel config files that made MMC support modules instead of built-in.  Since the modules are not loaded correctly, or do not function correctly as modules, the rootfs is not found, causing the boot to fail.

I suggest reverting the config changes until functional MMC module support has been completed.


Version-Release number of selected component (if applicable):

  3.6.0-0.rc3.git2.1.fc18 (and newer)


How reproducible:

  Always


Steps to Reproduce:
1.  Install latest kernel for OMAP or Tegra
2.  reboot
3.

  
Actual results:

  Fails to find the rootfs on the SDCard.


Expected results:

  Systems find the rootfs and completes the boot.


Additional info:

The last known-good version from F17 was: kernel-3.5.3-1.

Using the attached config changes (based on the 3.5.3 kernel), both systems boot from SDCard as expected.

Comment 1 Peter Robinson 2012-09-27 09:14:13 UTC
I have some issues with this patch. For OMAP at least it looks like we have a cleaner fix.

Comment 2 D. Marlin 2012-09-27 12:10:25 UTC
Specifically, what issues?

Do you have a scratch build that incorporates the 'cleaner fix' that we can test?

Comment 3 Peter Robinson 2012-10-17 12:29:11 UTC
Fixed in 3.6.1


Note You need to log in before you can comment on or make changes to this bug.