Bug 860886 - GDM shows a sad face on VirtualBox
GDM shows a sad face on VirtualBox
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-26 22:33 EDT by Mukundan Ragavan
Modified: 2012-12-16 12:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-16 12:57:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot 1 (shows gdm screen) (26.80 KB, image/png)
2012-09-26 22:33 EDT, Mukundan Ragavan
no flags Details
Screenshot 2 shows the "GDM" logged in screen. (27.50 KB, image/png)
2012-09-26 22:34 EDT, Mukundan Ragavan
no flags Details
log file attached. (25.64 KB, text/plain)
2012-09-27 09:44 EDT, Mukundan Ragavan
no flags Details
/var/log/gdm (23.72 KB, application/zip)
2012-10-05 07:09 EDT, Mukundan Ragavan
no flags Details
/var/log/messages (371.41 KB, application/octet-stream)
2012-10-05 07:09 EDT, Mukundan Ragavan
no flags Details
package list that supposedly fixed the issue (3.64 KB, text/plain)
2012-10-08 14:26 EDT, cornel panceac
no flags Details

  None (edit)
Description Mukundan Ragavan 2012-09-26 22:33:31 EDT
Created attachment 617859 [details]
Screenshot 1 (shows gdm screen)

Description of problem:

I installed F18 using the 20120926_F18b-smoke3 DVD iso on a Virtualbox VM. The installation completed without errors and showed the first boot screen.

At the end of completion of the first boot screen, however, GDM refused to load throwing the error "Oh no! Something has gone wrong" with the log out button enabled. Clicking on "Log out" returns to the same screen.

When I tried to shutdown the system, I got the regular "Shutdown" message. However, the pop-up informs that "GDM is logged in - which I believe should not be the case.


Version-Release number of selected component (if applicable):
I have no idea what component I should file the bug against. I chose GDM.

How reproducible:
Always

Steps to Reproduce:
1. Install F18b using the image described above (http://dl.fedoraproject.org/pub/alt/qa/18/20120926_f18b-smoke3/)

2. Complete first boot

  
Actual results:

Screenshot 1  shows the error I encounter.

Screenshot 2 shows the "shutdown message.


Expected results:

GDM should load and show the list of users.
Comment 1 Mukundan Ragavan 2012-09-26 22:34:23 EDT
Created attachment 617860 [details]
Screenshot 2 shows the "GDM" logged in screen.
Comment 2 Mukundan Ragavan 2012-09-27 09:44:31 EDT
Created attachment 618073 [details]
log file attached.
Comment 3 Mukundan Ragavan 2012-10-04 19:49:32 EDT
I am seeing this with F18-Beta-TC2 too. I do not see any xsession errors file in the home directory.
Comment 4 Mukundan Ragavan 2012-10-04 19:59:09 EDT
Logging in using VT and typing startx logs in to GNOME fine. So, I guess the issue is with GDM specifically(?).
Comment 5 Kamil Páral 2012-10-05 04:52:51 EDT
I have installed F18 Beta TC2 DVD GNOME and it works OK in KVM.

Can you attach /var/log/messages and all in /var/log/gdm ?
Comment 6 cornel panceac 2012-10-05 06:02:34 EDT
i've seen this yesterday, after latest updates, on my thinkpad x40 notebook.
Comment 7 cornel panceac 2012-10-05 06:03:45 EDT
before the updates, gdm was not starting at all, right now it shows just the sad face with the logout button greyed-out, since no login was performed :)
Comment 8 Mukundan Ragavan 2012-10-05 07:09:22 EDT
Created attachment 622105 [details]
/var/log/gdm

I have removed the earlier log file I had attached. The entire /var/log/gdm directory is installed.
Comment 9 Mukundan Ragavan 2012-10-05 07:09:52 EDT
Created attachment 622106 [details]
/var/log/messages
Comment 10 cornel panceac 2012-10-05 14:11:42 EDT
After today's updates, (selinux included), gdm shows up again. Thank you.
Comment 11 Kamil Páral 2012-10-08 08:14:53 EDT
(In reply to comment #10)
> After today's updates, (selinux included), gdm shows up again. Thank you.

Can you specify which packages you have updated? You can use "yum history" for that.
Comment 12 cornel panceac 2012-10-08 14:26:52 EDT
Created attachment 623650 [details]
package list that supposedly fixed the issue

i've found no way to use yum history for this, so i'll attach the package list from syslog. hopefully i've managed to identify the right day :)
Comment 13 Adam Williamson 2012-10-09 11:58:10 EDT
Out of that list I'd take a bet on selinux-policy.
Comment 14 Tim Flink 2012-12-13 04:34:04 EST
Is this still an issue? There've been no new reports for over 2 months. c#10 makes it sounds like this was fixed.
Comment 15 satellitgo 2012-12-16 12:25:47 EST
I have no problems in VirtualBox 4.2.4 with TC1 and TC2 lives netinstall and DVD both arches tested and work fine
Comment 16 Kamil Páral 2012-12-16 12:57:57 EST
Marking as fixed. Please reopen if you still see it.

Note You need to log in before you can comment on or make changes to this bug.