Bug 86098 - xhcat's standard word replacements should protect Red Hat Trademarks
xhcat's standard word replacements should protect Red Hat Trademarks
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: xchat (Show other bugs)
phoebe
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-13 16:39 EST by Seth Vidal
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-03 08:50:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2003-03-13 16:39:19 EST
Description of problem:

when someone on an irc channel types rh or rhl it is clearly diluting trademarks
for Red Hat - therefore the standard  word replaces should fit Red Hat over rh
and Red Hat Linux over rhl.

In addition, people typing redhat should probably be beaten, excluding the
website, of course. But if you type redhat it should expand out to Red Hat.

These are easy to do in xchat and would make for a more correct use of the terms.

A pity you can't fix people calling referring to the distro as RedHat instead of
Red Hat Linux.

Thanks
Comment 1 Mike A. Harris 2003-03-13 23:07:57 EST
I've already thought about these types of replacements in xchat myself:

rhl == Red Hat Linux
rh == Red Hat
redhat == Red Hat
rhl8 == Red Hat Linux 8.0
rhn == Red Hat Network

My own xchat does these already.  I would add them in a heartbeat, but I
have 2 concerns first:

1) Will they end up annoying people, and doing more harm than good

2) Will some people look at this type of a change as some sort of lame
   "Red Hat is evil like Microsoft" negative thing and complain that xchat
   should just do what the default xchat comes with.

Personally, I think making the change would be nice, because it is annoying
to me seeing people mistype these things all the time and abbreviate them
poorly, etc.  It would certainly help cut down on that.

It ultimately boils down to wether the change would do more good than bad,
and how people would perceive it once they start encountering it.  While
that is hard to guess, it is theoretically at least something I could
experiment with when the next development cycle opens up.  I could patch
xchat with these changes and see how people react.  I'm sure there will
be both good and bad reactions.

I'll also have to see what other Red Hat people think about this before
I consider adding it into future rawhide though.

I'll keep you posted.   
Comment 2 Mike A. Harris 2003-03-13 23:09:50 EST
Looking at the bug summary line, perhaps we should add a similar feature
to bugzilla:

xhcat -> xchat


/me *runs*
Comment 3 Luis Villa 2003-03-13 23:15:35 EST
I'd also suggest doing s/r*h*8.1/no, we might call it 9.0 or 314.15 or XP./
Comment 4 Seth Vidal 2003-03-13 23:16:49 EST
I see how it is, I try to help protect Red Hat's Trademarks and I get typo abuse.

and remember it could be Red Hat Linux - Electric Boogaloo.

;)
Comment 5 Mike A. Harris 2003-03-14 00:22:28 EST
Don't get me wrong...  ;o)

Of course we must protect our trademarks, and of course we want people to
spell our trademarked names properly, etc.  But someone misspelling "Red Hat"
as "redhat" in IRC isn't exactly breaking the law.  ;o)

As a Red Hat employee, it irritates me to see people not properly spell
"Red Hat", and "Red Hat Linux", "Red Hat Linux 8.0", etc. and also the
one that Luis points out above too.  ;o)

I correct people in IRC all the time of course, but they're not exactly
breaking the law.  ;o)

Here's a summary of the upside of adding this enhancement:

1) It allows Red Hat employees, as well as our users to be able to abbreviate
   what they type, rather than typing out the full blown blah blah blah every
   time it is typed, just to be pedantically correct (and yes, I am one of
   those pedantic people now, having been brainwashed^W trained well by msw)
   <grin>

2) It would help to turn ambiguous acronyms into their proper meanings

3) It would make the Red Hat branding more visible

4) It would help to stop people from driving us nuts (both Red Hatters, as
   well as other people who get annoyed by seeing things like "RH8") by
   abbreviating things all the time, and making up their own wrong/broken
   spellings, etc.

5) Some users would likely welcome the change, as it would allow them to type
   the abbreviated names, etc. but get the full blown proper names intended.


Downsides:
1) It would likely surprise some users, and perhaps irritate them that the
   software is doing something automatically for them, which they never asked
   it to do.

2) Some people would probably construe this as some evil Red Hat masterplan
   to take over the world

3) It would likely boost Slashdot's banner ad revenue stream.

4) It would not "protect" anything.


In short, it would be both a convenience to people like myself, you, and
other people who feel the same way.  It would cut down on the number of
people who annoy us all by mistyping and/or abbreviating things.  It would
likely annoy a lot of people however who want to just see exactly what
they type.

I asked some people in IRC on #redhat what they thought about it, and so far
both internal Red Hat feedback from developers as well as public feedback
from #redhat is leaning towards this not being a good idea (as much as i would
LOVE to add it).  ;o)

I'll ask the channel to look at this again when the channel is full tomorrow
to get some more opinions.
Comment 6 Mike A. Harris 2003-03-14 00:32:00 EST
Actually, I missed the "protect Red Hat Trademarks" part of the summary
and just caught that right now.  I disagree with that part.  If xchat
does corrections, it should just be to correct annoyances, not for
trademark reasons.
Comment 7 Mike A. Harris 2003-03-14 00:33:14 EST
Whoa.  Bugzilla is screwed up.  It mid-air-collisioned me, and ended
up putting the comments in the wrong order.  The last comment was written
prior to the last 2 comments from you guys.  ;o)
Comment 8 Miloslav Trmac 2003-03-14 10:57:29 EST
Add to the downsides:
5) Wasting screen space and having to read and {visually, mentally} parse
   "Red Hat Enterprise Linux AS" instead of just a simple, short unambiguous
   (and hopefully correct) abbreviation.
   BTW: Which one is it here? RHELAS?
Comment 9 Seth Vidal 2003-03-14 11:01:08 EST
You forgot to close the </sarcasm> tag.
Comment 10 Mike A. Harris 2003-04-03 08:50:12 EST
There is a universal sentiment by both Red Hat Linux users, and employees
of Red Hat that this suggestion would not be received well, is not wanted,
and that it does not "protect" anything.

After much thought and consideration, I believe they are right, and I will
not implement this request (as much as I would like to).  ;o)

Closing WONTFIX

Note You need to log in before you can comment on or make changes to this bug.