Bug 8610 - xawtv not as component in bugzilla, xawtv bug:v4l-conf not installed suid root, led font not installed
xawtv not as component in bugzilla, xawtv bug:v4l-conf not installed suid roo...
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: bugzilla (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-19 11:14 EST by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-19 13:06:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-01-19 11:14:45 EST
Bugzilla problem:
-xawtv is not available in bugzilla as a powertools component

Real bug: there are 2 problems with the xawtv 3.0.6 rpm in rawhide:
-v4l-conf is not installed suid root, this causes overlay mode to fail,
 and makes xawtv mostly useless.
-An unrelated problem is that the led font which is distributed with
 xawtv is not installed by the rpm.
Comment 1 Preston Brown 2000-01-19 13:06:59 EST
I am fixing the LED font problem now.

You must run v4l-conf as root.  It has not been security audited, and thus will
not be SUID root.
Comment 2 Hans de Goede 2000-01-19 13:16:59 EST
I understand, but v4l-conf is not called by me (the user) but by xawtv itself,
I believe it was specificly designed todo the dirty root work for xawtv and
nothing else. But your right.

Any chance you can get it audited somewhere in the future?

Note You need to log in before you can comment on or make changes to this bug.