Bug 861003 - Liberation Mono is not being recognized as a monospaced font
Liberation Mono is not being recognized as a monospaced font
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
x86_64 Windows
unspecified Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 05:54 EDT by Andreas Schöneck
Modified: 2012-10-05 01:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 01:01:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Schöneck 2012-09-27 05:54:37 EDT
Description of problem:
The Liberation Mono font is not being recognized as a monospaced font under various Windows applications, such as HippoEdit.

Version-Release: liberation-fonts-ttf-2.00.0

How reproducible: Always.

Steps to Reproduce:
1. Open HippoEdit
2. Go to Tools/Options
3. Navigate to Syntax Settings/Basic/Fonts And Colors
4. Be sure that "Show only monospaced fonts" is checked.

Actual results:
Liberation Mono is not shown in the list.

Expected results:
Liberation Mono is shown in the drop down box.

Additional info:
* Using Windows 7 SP1 x86_64
* Using HippoEdit 1.50.776 for Win 64 bit
* Manually removed all old Liberation*.ttf from Windows\Fonts and rebooted prior to installation of version 2.00.0.
Comment 1 Pravin Satpute 2012-09-27 06:51:07 EDT
I can reproduce it. searching for root cause behind this. This is problem of conversion from ttf to .sfd
Comment 2 Pravin Satpute 2012-10-01 07:46:28 EDT
I discussed this on fontforge users list and found reason behind this is LiberationMono has many 0 width characters other than Fixed width 1229.

Presently fontforge does not set isFixedPitch bit if any character has other than decided fixed width. Some applications use this bit to decide font is monospace or not.

Hoping to find any alternative to fix this bit or may be fontforge upstream will fix this bug.
Comment 3 Paul Flo Williams 2012-10-01 08:00:03 EDT
(In reply to comment #2)
> 
> Hoping to find any alternative to fix this bit or may be fontforge upstream
> will fix this bug.

As inconvenient as this is, it is not a bug in FontForge. As I've just posted on the FF users' list, DejaVu Sans Mono handles this in a way that keeps everyone happy. If only the technique was better documented somewhere!
Comment 4 Andreas Schöneck 2012-10-01 08:06:28 EDT
FWIW, I had the problem with some earlier version (I think it was 1.07), being fixed in a minor release (must have been 1.07.1) afterwards - maybe "accidentally".

Anyway, that release (1.07.1) of Liberation Mono was correctly recognized as a monospaced font.
Comment 5 Pravin Satpute 2012-10-03 00:52:54 EDT
(In reply to comment #3)
> 
> As inconvenient as this is, it is not a bug in FontForge. As I've just
> posted on the FF users' list, DejaVu Sans Mono handles this in a way that
> keeps everyone happy. If only the technique was better documented somewhere!

Yeah, its clear. This is not issue with Fontforge but issue with Proprietary font editors not following standards.

I will fix this issues using fontTools. In long term will do necessary changes to make it true Monospace font.
Comment 6 Fedora Update System 2012-10-04 12:13:29 EDT
liberation-fonts-2.00.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/liberation-fonts-2.00.1-1.fc18
Comment 7 Fedora Update System 2012-10-04 13:52:47 EDT
Package liberation-fonts-2.00.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liberation-fonts-2.00.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15393/liberation-fonts-2.00.1-1.fc18
then log in and leave karma (feedback).
Comment 8 Andreas Schöneck 2012-10-04 15:10:32 EDT
Release 2.00.1 from this site https://fedorahosted.org/liberation-fonts/ fixes the issue for me.

HippoEdit is able to recognize Liberation Mono as a monospaced font. So is Directory Opus (it allows only monospaced fonts to be used in hex viewer).
Comment 9 Pravin Satpute 2012-10-05 01:01:03 EDT
thanks for confirmation, closing bug

Note You need to log in before you can comment on or make changes to this bug.