Bug 861020 - [US2597][fork] need do some update in man rhc-app, rhc and rhc-app --help rhc --hep
[US2597][fork] need do some update in man rhc-app, rhc and rhc-app --help rh...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 06:20 EDT by Rony Gong
Modified: 2015-05-14 22:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_194
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:50:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-09-27 06:20:26 EDT
Description of problem:
1. since rhc app cartridge and rhc app snapshot change to rhc cartridge and rhc snapshot
it  shouldn't show cartridge and snapshot in man rhc-app(rhc app -h), should show their help info in man rhc(rhc -h)
2. since rhc app destroy change to rhc app delete, it shouldn't show replace destroy with delete  in man rhc app and rhc-app --help


Version-Release number of selected component (if applicable):
fork_ami_US2597_US2599_US2813_US2817_US2872_172

How reproducible:
always


Steps to Reproduce:
1.man rhc-app  or rhc-app --help
2.man rhc  or rhc --help
3.
  
Actual results:
man rhc-app
       create Bind a registered rhcloud user to a domain in rhcloud.

       show   Display information about a user

       start  Starts the application (includes embedded)

       stop   Stops the application (includes embedded)

       force-stop
              Stops all application processes

       restart
              Restart the application

       reload Reloads application configuration

       status Returns application status

       destroy
              Destroys the application. This is not reversible and will stop your application and then remove the application and repo from the remote server.  No local changes are made.

       tidy   Garbage collects the git repo and empties log/tmp dirs

       add-alias
              Add a custom domain name for the application

       remove-alias
              Remove a custom domain name for the application

       tail   Tail the logs of an application

       snapshot
              Saves/Restores an application snapshot to/from a tarball at the location specified using --filepath (default: ./$APPNAME.tar.gz)

       cartridge
              Manage an embedded cartridge for the application

Additional info:
Comment 1 John (J5) Palmieri 2012-10-01 12:55:10 EDT
rhc-app --help will not change since that is the old code and still takes the old interfaces but prints out a deprecated message at the top.

rhc app --help should work fine.

TODO:

 * fixing up the man page for rhc app

 * creating a new man page for rhc cartridge
Comment 2 John (J5) Palmieri 2012-10-01 13:24:47 EDT
fixed
Comment 3 Chandrika Gole 2012-10-02 17:17:30 EDT
verified on AMI: fork_ami_US2597_US2599_US2813_US2817_US2872_186 (ami-19f04d70)

Note You need to log in before you can comment on or make changes to this bug.