Bug 861037 - Eclipse does not start in rawhide
Eclipse does not start in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 07:22 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 03:24:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-09-27 07:22:27 EDT
Reported by rgrunber. Happens only for 4.2.1-0.x. Works in f17 and f18.
Comment 1 Krzysztof Daniel 2012-09-27 07:26:30 EDT
Initial investigation revealed 

java.lang.LinkageError: loader constraint violation in interface itable initialization: when resolving method "org.eclipse.e4.ui.css.core.impl.dom.CSSStyleSheetImpl.getParentStyleSheet()Lorg/w3c/dom/stylesheets/StyleSheet;" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, org/eclipse/e4/ui/css/core/impl/dom/CSSStyleSheetImpl, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for interface org/w3c/dom/stylesheets/StyleSheet have different Class objects for the type tImpl.getParentStyleSheet()Lorg/w3c/dom/stylesheets/StyleSheet; used in the signature
Comment 2 Krzysztof Daniel 2012-09-28 07:08:45 EDT
There is an unwanted wiring during bundles resolution here. Many UI
packages required package org.w3.dom.css which was provided by a bundle
in the upstream Eclipse, but is provided by vm SDK in Fedora. The
problem is that it is also provided by javax.xml, and since there are
duplicates, some classes are loaded from javax.xml bundle in some
bundles and others from SDK in other bundles, causing LinkageErrors
and/or class cast exceptions. 
The solution is to remove imports from the UI code to ensure that
javax.xml is not searched during class resolution, and that proper
classes from SDK are used.
Comment 3 Krzysztof Daniel 2012-10-01 03:45:44 EDT
New Eclipse build http://koji.fedoraproject.org/koji/taskinfo?taskID=4545903
Comment 4 Roland Grunberg 2012-10-01 10:16:21 EDT
I've tried out the 4.2.1-0.4 build and can confirm it fixes the issue.

Note You need to log in before you can comment on or make changes to this bug.