Bug 861049 - Fedora 16 and 17 guests hang during boot
Fedora 16 and 17 guests hang during boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: ZStream
Depends On: 839156
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 07:52 EDT by Chris Pelland
Modified: 2012-12-18 14:45 EST (History)
25 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.295.el6_3.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 14:45:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2012-09-27 07:52:20 EDT
This bug has been copied from bug #839156 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 7 Qunfang Zhang 2012-10-22 01:52:32 EDT
Reproduced this issue on qemu-kvm-0.12.1.2-2.295.el6 and qemu-kvm-rhev-0.12.1.2-2.295.el6, and verified pass on qemu-kvm-0.12.1.2-2.295.el6_3.4 and qemu-kvm-rhev-0.12.1.2-2.295.el6_3.4.

Steps:
1. Install a Fedora 17 guest with pty console chardev.

# /usr/libexec/qemu-kvm  -m 2048 -smp 1,sockets=1,cores=1,threads=1 -enable-kvm -name fedora17-67 -uuid 11caa689-717d-4851-9800-908a55ee7d98 -k en-us -rtc base=localtime,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=input0 -drive file=/home/fedoar17-64.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=koTUXQrb,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/home/boot.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:10:40:72:12:1b,bus=pci.0,addr=0x5 -monitor stdio -qmp tcp:0:6667,server,nowait -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=4,bus=pci.0,addr=0x7 -chardev pty,id=channel0 -device virtconsole,bus=virtio-serial0.0,chardev=channel0,name=org.fedoraproject.console.foo,id=console1,nr=1 -vnc :11 -boot dc

In the unfixed version qemu-kvm(-rhev)-0.12.1.2-2.295.el6, guest hangs at the beginning of installation, and consume 100% cpu. 
In the fixed version qemu-kvm(-rhev)-0.12.1.2-2.295.el6_3.4, guest doesn't hang and proceed the installation until finished.

And also tried the unix socket (instead the problematic pty), guest doesn't hang during installation in both fixed and unfixed version.

So this bug is verified pass.
Comment 9 errata-xmlrpc 2012-12-18 14:45:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1585.html

Note You need to log in before you can comment on or make changes to this bug.