This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 861054 - $HOME/.config/fontconfig/fonts.conf ignored
$HOME/.config/fontconfig/fonts.conf ignored
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 08:29 EDT by Marcus Moeller
Modified: 2012-10-09 23:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 23:07:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2012-09-27 08:29:06 EDT
I have created a fonts.conf configuration file $HOME/.config/fontconfig/fonts.conf with the following content:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
       <match target="font" >
              <edit mode="assign" name="rgba" >
                     <const>none</const>
              </edit>
       </match>
       <match target="font" >
              <edit mode="assign" name="hinting">
                     <bool>true</bool>
              </edit>
       </match>
       <match target="font" >
               <edit mode="assign" name="hintstyle">
               <const>hintfull</const>
               </edit>
       </match> 	
</fontconfig>


According to xrdb -q (after re-login) the following values are set:

Xft.dpi:	96
Xft.hinting:	true
Xft.hintstyle:	hintmedium

So the config seems to be ignored.
Comment 1 Akira TAGOH 2012-09-27 22:12:34 EDT
fontconfig itself doesn't apply own config to X resources. try fc-match -v and see those values are applied there. given that it's a bug, I have no idea who is responsible.
Comment 2 Marcus Moeller 2012-09-28 02:58:25 EDT
Yes fc-match -v lists the correct settings. So do you have any ideas why they are not applied to X resources?
Comment 3 Akira TAGOH 2012-09-28 03:50:47 EDT
At least I can see hardcoding X resources in /etc/X11/Xresources. again, I have no idea who is responsible to _update_. anyway, it's not a bug for fontconfig. if you are not sure where this should be reassigned to, I'll close this.
Comment 4 Akira TAGOH 2012-10-09 23:07:12 EDT
Please reopen and correct the component if you see who's responsible to update Xresources for that.

Note You need to log in before you can comment on or make changes to this bug.