Bug 8611 - Dosemu doesn't support ps2 imwheel mouses
Dosemu doesn't support ps2 imwheel mouses
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dosemu (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-19 11:22 EST by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-19 11:45:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzipped patch to add imps2 support to dosemu (2.53 KB, application/octet-stream)
2000-01-19 11:23 EST, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2000-01-19 11:22:04 EST
The internal mouse driver of dosemu doesn't support imwheel mouses,
making it impossible to use such a mouse with dosemu, unless the mouse
is setup as ps2 mouse everywhere (both under X and gpm and svgalib)

The problem is that an imwheel mouse is ps2 compatible untill initialised
as imwheel mouse. So once X or gpm is started with imwheel support,
dosemu's ps2 mouse driver doesn't work anymore.

I have a clean patch which adds imwheel support to dosemu-0.99.13.

I'll attach said patch to this bugreport.
Comment 1 Hans de Goede 2000-01-19 11:23:59 EST
Created attachment 65 [details]
gzipped patch to add imps2 support to dosemu
Comment 2 Hans de Goede 2000-01-19 11:28:59 EST
Ehm hint, the patch should be applied with -R (oops)
Comment 3 Bill Nottingham 2000-01-19 11:45:59 EST
Applied in dosemu-0.99.13-3.
Comment 4 Hans de Goede 2000-02-01 10:54:59 EST
Thanks for incorperating my patch, this makes life a lott easier for me, but for
other people it might be handy to add a note to the sample dosemu.conf and a
README.redhat explaining that with RedHat's version imps2 is a support and valid
mouse type.


For dosemu.conf I suggest changing:
$_mouse = "microsoft"   # one of: microsoft, mousesystems, logitech, mmseries
                        # mouseman, hitachi, busmouse, ps2

To:
$_mouse = "microsoft"   # one of: microsoft, mousesystems, logitech, mmseries
                        # mouseman, hitachi, busmouse, ps2, imps2

For README.redhat I suggest:
This version of dosemu supports ps2 microsoft intellimouse or compatible
(logitech mouseman+ / firstmouse+).
To use it set $_mouse to "imps2" in /etc/dosemu.conf.
Comment 5 Cristian Gafton 2000-02-01 10:55:59 EST
bill?

Note You need to log in before you can comment on or make changes to this bug.