Bug 861101 - Broken download of one package stops whole transaction without an obvious way how to continue
Broken download of one package stops whole transaction without an obvious way...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: PackageKit (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 09:59 EDT by Matěj Cepl
Modified: 2013-10-29 20:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-29 20:45:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2012-09-27 09:59:25 EDT
Description of problem:
Even on the internal repository (without any duplicate mirrors) it can happen that some packages are not downloaded because of Internet issues. 

It would be nice if the Update Viewer provided something more leading than just an Error message.


Version-Release number of selected component (if applicable):
gnome-packagekit-3.5.90-1.el7.x86_64

How reproducible:
happened once

Steps to Reproduce:
1.run Update from internal repository (so there are no mirrors) with problematic connection (over VPN for example)
2.
3.
  
Actual results:
error message with no hints what to do next

Expected results:
if one of 556 packages has not been downloaded, put to the error box another button "Try again" or something in that style

Additional info:
Comment 2 Richard Hughes 2013-05-07 15:54:53 EDT
This feature enhancement needs to be upstream in bugzilla.gnome.org -- thanks.
Comment 3 Matthias Clasen 2013-10-29 20:45:51 EDT
We are not going to do this for rhel7.0 at this point

Note You need to log in before you can comment on or make changes to this bug.