Bug 861113 - FTP client does not expand home directory correctly after sudo or su
FTP client does not expand home directory correctly after sudo or su
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ftp (Show other bugs)
6.1
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Synacek
Lukas "krteknet" Novy
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 10:26 EDT by Danny Oscar Kip
Modified: 2014-02-18 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 04:16:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[Patch] don't use getlogin() (1.05 KB, patch)
2012-10-03 03:42 EDT, Jan Synacek
no flags Details | Diff

  None (edit)
Description Danny Oscar Kip 2012-09-27 10:26:56 EDT
Description of problem:
When using FTP client from a shell with elevated rights through sudo (or su for that matter), FTP client assumes the uid from /proc/self/loginuid to be the uid of the user, and expands ~ to the originating user, not the user initiating the FTP client.

Version-Release number of selected component (if applicable):
Seen on both RHEL6.1 and RHEL5.3, no other version tested yet.


How reproducible:

Start an ftp client after sudo, and try an lcd command.

Steps to Reproduce:
1. use sudo or su to open a shell as another user (in this example: 'appl5')
2. start ftp client
3. type 'lcd ~/', 'lcd' or 'lcd ~'
  
Actual results:
[user3@host ~]$ sudo -i -u appl5
Password: 
[appl5@host ~]$ ftp
ftp> lcd
local: /home/user3: Permission denied
ftp> 

Expected results:

Local directory now /home/appl5
ftp> 


Additional info:

This bug does not appear in lftp or the ftp version supplied by Debian (both tested)
Comment 2 Danny Oscar Kip 2012-09-28 03:15:35 EDT
The fact that FTP client takes itΕ› user from /proc/self/loginuid also causes it to propose that originating user as the login user, which is also not correct. But that is not usually a problem, since you can easily supply the user.
Comment 3 Jan Synacek 2012-10-03 03:42:19 EDT
Created attachment 620658 [details]
[Patch] don't use getlogin()

Quoting man getlogin(3):

"getlogin() returns a pointer to a string containing the name of the user logged in on the controlling terminal of the process"

"Unfortunately, it is often rather easy to fool getlogin(). Sometimes it does not work at all, because some program messed up the utmp file. Often, it gives only the first 8 characters of the login name. The user currently logged in on the controlling tty of our program need not be the user who started it. Avoid getlogin() for security-related purposes."
Comment 4 Danny Oscar Kip 2012-10-04 07:17:36 EDT
Just in case nobody noticed: my example was incorrectly pasted, there is a ~ missing after the 'lcd' command. 

Just issueing 'lcd' will only display your current local dir, not change it. Though I would consider this unexpected behaviour (as 'cd' would take you to your homedir in a shell), and it really would need a 'lpwd' to replace this, the example of this bug as I provided would be an incorrect representation of the actual bug. 

So please use 'lcd ~' to reproduce correctly.
Comment 5 Jan Synacek 2012-10-04 07:27:38 EDT
Even the default username just after the connection was not correct. Ftp was using getlogin() which simply doesn't work correctly in this case.
Comment 6 Danny Oscar Kip 2012-10-04 07:51:03 EDT
The ftp client from the Kerberos workstation package exhibits the same behaviour.
In my particular case: 
/usr/kerberos/bin/ftp from krb5-workstation-1.6.1-31.el5_3.3.i386

Interestingly, that implementation does in fact go to the homedir when entering just 'lcd', instead of just behaving like a local 'pwd' (as /usr/bin/ftp does)

The plot thickens :)
Comment 13 errata-xmlrpc 2013-05-21 04:16:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0845.html

Note You need to log in before you can comment on or make changes to this bug.