Bug 861114 - greater window width when nologin message to long
Summary: greater window width when nologin message to long
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1566211
TreeView+ depends on / blocked
 
Reported: 2012-09-27 14:28 UTC by Tomas Pelka
Modified: 2018-04-11 19:17 UTC (History)
4 users (show)

Fixed In Version: gdm-2.30.4-42.el6
Doc Type: Bug Fix
Doc Text:
Cause: Long authentication messages stretch the login window to an unreasonable width. Consequence: The login window gets unreasonably wide if authentication messages are too long. Fix: Force authentication messages to wrap if they get too long. Result: Long authentication messages no longer stretch the login window to an unreasonable size.
Clone Of:
: 1566211 (view as bug list)
Environment:
Last Closed: 2013-11-21 23:32:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1708 normal SHIPPED_LIVE gdm bug fix update 2013-11-21 00:39:27 UTC

Description Tomas Pelka 2012-09-27 14:28:59 UTC
Description of problem:
Gdm-greater window is going to follow text width of /etc/nologin. In case nologin message is really long greater window might go outside of visible screeen

Version-Release number of selected component (if applicable):
gdm-2.30.4-33.el6

How reproducible:
100%

Steps to Reproduce:
1. put very long text without "/n" to /etc/nologin
echo "veeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeery looooooooooooooooooooooooooooooooooooooooooooooooooooooong text" > /etc/nologin
2. try to relogin
3.
  
Actual results:
width of gdm greater can go ouf of visible screeen

Expected results:
text should be auto wrapped if possible

Additional info:

Comment 1 Ray Strode [halfline] 2013-06-05 14:34:20 UTC
devack+

Comment 6 Ray Strode [halfline] 2013-08-12 21:26:21 UTC
should be set in gdm-2.30.4-42.el6

Comment 11 errata-xmlrpc 2013-11-21 23:32:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1708.html


Note You need to log in before you can comment on or make changes to this bug.