Bug 861130 - systemd[1]: segfault at 7d ip b7420447 sp bffdc2a8 error 4 in libc-2.16.so[b73a0000+1af000]
systemd[1]: segfault at 7d ip b7420447 sp bffdc2a8 error 4 in libc-2.16.so[b7...
Status: CLOSED DUPLICATE of bug 859721
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 11:18 EDT by John Ellson
Modified: 2012-09-27 12:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 12:40:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2012-09-27 11:18:45 EDT
Description of problem:
I had just complete a yum update of a Fedora 18 i686 virtual host, which included a new kernel and, I think, a new glibc.   After reboot the system died with:

[ 3.389621 ] systemd[1]: Initializing machine ID from KVM UUID.
[ 3.449751 ] cp (46) used greatest stack depth: 6092 bytes left
[ 3.483763 ] systemd[1]: segfault at 7d ip b7420447 sp bffdc2a8 error 4 in libc-2.16.so[b73a0000+1af000]
[ 3.532271 ] systemd (47) used greatest stack depth: 6044 bytes left
[ 3.553110 ] systemd[1]: Caught <SEGV>, dumped core as pid 47.
[ 3.573351 ] systemd[1]: Freezing execution.


Version-Release number of selected component (if applicable):
Unable to positively verify these, but from a Fedora-18 x86_64 host that was updated at the same time, I think the versions are:
kernel-3.6.0-0.rc7.git1.4.fc18
systemd-191-2.fc18
glibc-2.16-15.fc18


How reproducible:
100%
Trying with the previous kernel has the same result.
Trying with selinux=0 has the same result.


Steps to Reproduce:
1. reboot
2. 
3.
  
Actual results:
Bricked system

Expected results:
Working system

Additional info:
Comment 1 Lennart Poettering 2012-09-27 12:40:07 EDT

*** This bug has been marked as a duplicate of bug 859721 ***

Note You need to log in before you can comment on or make changes to this bug.