Bug 861134 - [TEXT] webadmin: after template copy to multiple domains we show "2 SDs" in the disks tab storage domain(s) column
[TEXT] webadmin: after template copy to multiple domains we show "2 SDs" in t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity low
: ---
: 3.2.0
Assigned To: Vered Volansky
vvyazmin@redhat.com
storage
: EasyFix, ZStream
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-09-27 11:38 EDT by Dafna Ron
Modified: 2016-02-10 12:16 EST (History)
10 users (show)

See Also:
Fixed In Version: sf3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot (60.86 KB, image/jpeg)
2012-09-27 11:38 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10558 None None None Never

  None (edit)
Description Dafna Ron 2012-09-27 11:38:23 EDT
Created attachment 618150 [details]
screen shot

Description of problem:

after we copy a template disks to other storage domains, the column "Storage Domain(s) reports "2 SDs"
I don't this looks good... I think we should write the actual words (2 Storage Domains) instead of using initials. 

Version-Release number of selected component (if applicable):

si19

How reproducible:

100%

Steps to Reproduce:
1. copy a templates disk 
2.
3.
  
Actual results:

we are using initials for Storage Domains which I don't think looks good. 

Expected results:

we should write the actual words: 2 Storage Domains

Additional info: screen shot
Comment 3 Allon Mureinik 2012-09-29 13:04:14 EDT
Seems like a pretty straightforward fix - just fix the default in CommonApplicationConstants

Vered - please verify that this is all that's needed and there are no I18N issues, and go for it.
Comment 4 Ayal Baron 2012-11-07 05:25:33 EST
Need to consider whether the text can fit in the screen.  Need to also consider width of text after localization (i.e. needs to look good in Japanese and other languages as well).
Comment 5 Ayal Baron 2012-12-19 05:24:48 EST
After looking at the screen shot we can just change "SDs" to "Domains".  since the column name is already 'Storage Domains" then "2 Domains" is guaranteed to be shorter.
Comment 6 Vered Volansky 2013-01-03 03:09:25 EST
Done.
http://gerrit.ovirt.org/#/c/10558
Change-Id: I8b256a5b92fbd2509b3860df1e17dbba0fd1ea3d
Comment 7 vvyazmin@redhat.com 2013-01-23 04:28:31 EST
No issues are found

Verified on RHEVM 3.2 - SF03 environment 

RHEVM: rhevm-3.2.0-4.el6ev.noarch
VDSM: vdsm-4.10.2-3.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-13.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
Comment 8 Itamar Heim 2013-06-11 05:41:26 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 05:41:56 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 05:54:12 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.