Bug 861152 - simfs missing in hrStorage in an OpenVZ container
simfs missing in hrStorage in an OpenVZ container
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp (Show other bugs)
6.3
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Safranek
Dalibor Pospíšil
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 12:10 EDT by Romain LE DISEZ
Modified: 2013-02-21 05:27 EST (History)
1 user (show)

See Also:
Fixed In Version: net-snmp-5.5-44.el6
Doc Type: Bug Fix
Doc Text:
same as #846532
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:27:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add support for simfs (1.24 KB, patch)
2012-10-01 12:16 EDT, Romain LE DISEZ
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0421 normal SHIPPED_LIVE net-snmp bug fix and enhancement update 2013-02-20 15:49:35 EST

  None (edit)
Description Romain LE DISEZ 2012-09-27 12:10:54 EDT
On RHEL 6.3, with the default net-snmp package (net-snmp 1:5.5-41.el6_3.1), I can't get the root partition of an OpenVZ container via SNMP. This bug makes the monitoring of diskspace impossible.

>>>>>>>>>>>>>>>>>>>>>>>
# snmpwalk  -v 2c -c public  server.example.com  hrStorageDescr
HOST-RESOURCES-MIB::hrStorageDescr.1 = STRING: Physical memory
HOST-RESOURCES-MIB::hrStorageDescr.3 = STRING: Virtual memory
HOST-RESOURCES-MIB::hrStorageDescr.6 = STRING: Memory buffers
HOST-RESOURCES-MIB::hrStorageDescr.7 = STRING: Cached memory
HOST-RESOURCES-MIB::hrStorageDescr.10 = STRING: Swap space
<<<<<<<<<<<<<<<<<<<<<<<


If I recompile the SRPM after I disabled the application of Patch23: net-snmp-5.5-hrFSTable-indexes.patch in the SPEC file, everything works fine, I can monitor the diskspace.

>>>>>>>>>>>>>>>>>>>>>>>
# snmpwalk  -v 2c -c public  server.example.com  hrStorageDescr
HOST-RESOURCES-MIB::hrStorageDescr.1 = STRING: Physical memory
HOST-RESOURCES-MIB::hrStorageDescr.3 = STRING: Virtual memory
HOST-RESOURCES-MIB::hrStorageDescr.6 = STRING: Memory buffers
HOST-RESOURCES-MIB::hrStorageDescr.7 = STRING: Cached memory
HOST-RESOURCES-MIB::hrStorageDescr.10 = STRING: Swap space
HOST-RESOURCES-MIB::hrStorageDescr.31 = STRING: /
<<<<<<<<<<<<<<<<<<<<<<<

(the following does not apply anymore when Patch23 is not applied)
Patch30: net-snmp-5.5-gfs.patch
Patch46: net-snmp-5.5-xfs.patch
Patch61: net-snmp-5.5-hrStorage-realStorageUnits.patch
Patch62: net-snmp-5.5-hrStorage-realStorageUnits2.patch
Patch63: net-snmp-5.5-hrStorage-fs.patch


This bug appeared in RHEL 5.7

I am a user of CentOS, the problem is also in Fedora. I hadn't tested on RHEL but I'm pretty sure it has the same bug.
Comment 2 Romain LE DISEZ 2012-10-01 12:16:27 EDT
Created attachment 619864 [details]
Add support for simfs

I'm not an net-snmp expert, but this patch works for me. I just used the one for XFS as a base.
Comment 4 RHEL Product and Program Management 2012-10-08 03:19:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 9 errata-xmlrpc 2013-02-21 05:27:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0421.html

Note You need to log in before you can comment on or make changes to this bug.