Bug 861167 - pull in new MADV_DONTDUMP flag for madvise system call
pull in new MADV_DONTDUMP flag for madvise system call
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jeff Law
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 13:21 EDT by Jason Baron
Modified: 2016-11-24 10:57 EST (History)
3 users (show)

See Also:
Fixed In Version: glibc-2.12-1.102.el6
Doc Type: Bug Fix
Doc Text:
Cause: glibc included in RHEL 6 does not define MADV_DONTDUMP or MADV_DODUMP Consequence: Code which relies upon those capabilities will not compile. Fix: MADV_DONTDUMP and MADV_DODUMP have been added to mman.h Result: Code which uses those macros should compile.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:05:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Potential patch, untested (4.27 KB, patch)
2012-09-27 13:48 EDT, Jeff Law
no flags Details | Diff

  None (edit)
Description Jason Baron 2012-09-27 13:21:11 EDT
Description of problem:

I'm adding support for 'MADV_DONTDUMP' to the qemu-kvm package for 6.4, in order to support a mode in which guest memory is not included in a core dump - see bz #859447. I've posted patches adding 'MADV_DONTDUMP' to the kernel for 6.4. I would like to see these headers pulled into glibc for 6.4, so that I can make use of them. I also need these updated glibc headers pulled into the build root for 6.4. Thanks.

How reproducible:

Try using 'MADV_DONTDUMP' and it is not defined.
Comment 2 Jeff Law 2012-09-27 13:48:09 EDT
Created attachment 618220 [details]
Potential patch, untested
Comment 3 Jeff Law 2012-09-27 13:49:01 EDT
No objections from me.  Note that PM & QE will have to sign off for this to get into 6.4 though.
Comment 5 errata-xmlrpc 2013-02-21 02:05:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0279.html

Note You need to log in before you can comment on or make changes to this bug.