Bug 861189 - make: INTERNAL: Exiting with 3 jobserver tokens available; should be 2!
Summary: make: INTERNAL: Exiting with 3 jobserver tokens available; should be 2!
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: make
Version: 6.3
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Patsy Griffin
QA Contact: Martin Cermak
Clayton Spicer
URL:
Whiteboard:
Depends On:
Blocks: 1271375
TreeView+ depends on / blocked
 
Reported: 2012-09-27 18:31 UTC by Mikuláš Patočka
Modified: 2016-05-10 21:14 UTC (History)
4 users (show)

Fixed In Version: make-3.81-22.el6
Doc Type: Bug Fix
Doc Text:
Parallel builds no longer terminate unexpectedly Previously, a bug caused the *make* utility to display an error message and terminate unexpectedly when executing parallel builds. This has now been fixed, and parallel builds no longer crash due to this bug.
Clone Of:
Environment:
Last Closed: 2016-05-10 21:14:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0827 0 normal SHIPPED_LIVE make bug fix update 2016-05-10 22:40:53 UTC

Description Mikuláš Patočka 2012-09-27 18:31:03 UTC
Description of problem:
Make exits with internal error

Version-Release number of selected component (if applicable):
make-3.81-20.el6.x86_64

How reproducible:
not reproducible, it is supposedly a race condition

Steps to Reproduce:
I ran "make -j2 2>&1|tee mk.log" to build RHEL 6 kernel.

Actual results:
drivers/input/mouse/sentelic.c: In function 'fsp_init':
drivers/input/mouse/sentelic.c:827: error: implicit declaration of function 'kzalloc'
cc1: warnings being treated as errors
drivers/input/mouse/sentelic.c:827: error: assignment makes pointer from integer without a cast
make[3]: *** [drivers/input/mouse/sentelic.o] Error 1
make[2]: *** [drivers/input/mouse] Error 2
make[1]: *** [drivers/input] Error 2
make[1]: *** Waiting for unfinished jobs....
make: *** [drivers] Error 2
make: INTERNAL: Exiting with 3 jobserver tokens available; should be 2!


Expected results:
make should not exit with an internal error

Additional info:

Comment 2 Mikuláš Patočka 2012-09-27 18:42:55 UTC
See this
http://old.nabble.com/fix-for-make-gaining-jobserver-tokens-td32720569.html
--- there is a fix.

Comment 3 RHEL Program Management 2013-10-14 00:25:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 13 errata-xmlrpc 2016-05-10 21:14:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0827.html


Note You need to log in before you can comment on or make changes to this bug.