Bug 861227 - lvconvert --stripes|--stripesize options appear worthless
lvconvert --stripes|--stripesize options appear worthless
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Peter Rajnoha
Cluster QE
:
Depends On: 711890
Blocks: 807971
  Show dependency treegraph
 
Reported: 2012-09-27 17:17 EDT by Corey Marthaler
Modified: 2013-11-21 18:17 EST (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.100-1.el6
Doc Type: Bug Fix
Doc Text:
The lvconvert command now uses a more strict checking of the --stripes and --stripesize options and errors out on combinations which are not applicable. The --stripes and --stripesize options can now be used together with --mirrors/--repair/--thinpool and --type raid*/mirror lvconvert options only.
Story Points: ---
Clone Of: 711890
Environment:
Last Closed: 2013-11-21 18:17:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Corey Marthaler 2012-09-27 17:19:35 EDT
Exists in the latest 6.4 rpms as well.

2.6.32-279.el6.x86_64
lvm2-2.02.97-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
lvm2-libs-2.02.97-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
lvm2-cluster-2.02.97-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
Comment 2 Peter Rajnoha 2012-12-11 10:09:52 EST
Patch is upstream now (v2.02.99):

http://git.fedorahosted.org/cgit/lvm2.git/commit/?id=cad22be3942809bac979d42195ea5a861a91a71f

It allows the --stripes/--stripesize only with lvconvert --mirrors, --repair and --thinpool where it does make sense, otherwise, you get an error message:

$ lvconvert --merge --stripes 2 vg/lvol0
  --stripes or --stripesize argument is only valid with --mirrors, --repair or --thinpool
  Run `lvconvert --help' for more information.

Man page has been updated accordingly - it's also mentioned that --stripes works for newly allocated space only.
Comment 5 Nenad Peric 2013-08-14 07:56:01 EDT
[root@tardis-01 ~]# lvcreate -n L -L 100M mirror
  Logical volume "L" created
[root@tardis-01 ~]# lvcreate -n M -m 1 -L 100M mirror
  Logical volume "M" created
[root@tardis-01 ~]# lvcreate -n S -i 2 -L 100M mirror
  Using default stripesize 64.00 KiB
  Rounding size (25 extents) up to stripe boundary size (26 extents).
  Logical volume "S" created


[root@tardis-01 ~]# lvconvert --stripes 2 mirror/L
  --stripes or --stripesize argument is only valid with --mirrors/--type mirror/--type raid*, --repair and --thinpool
  Run `lvconvert --help' for more information.

[root@tardis-01 ~]# lvconvert --stripes 2 mirror/L
  --stripes or --stripesize argument is only valid with --mirrors/--type mirror/--type raid*, --repair and --thinpool
  Run `lvconvert --help' for more information.

[root@tardis-01 ~]# lvconvert -m2 --stripes 2 mirror/M
  Using default stripesize 64.00 KiB
[root@tardis-01 ~]# lvs -a -o lv_name,devices
  LV              Devices                                  
  L               /dev/sdc1(513)                           
  M               M_rimage_0(0),M_rimage_1(0),M_rimage_2(0)
  [M_rimage_0]    /dev/sdc1(539)                           
  [M_rimage_1]    /dev/sdd1(1)                             
  [M_rimage_2]    /dev/sde1(1)                             
  [M_rmeta_0]     /dev/sdc1(538)                           
  [M_rmeta_1]     /dev/sdd1(0)                             
  [M_rmeta_2]     /dev/sde1(0)                             
  S               /dev/sdc1(564),/dev/sdd1(26)             
  [lvol0_pmspare] /dev/sdc1(0)                             
  origin                                                   
  pool            pool_tdata(0)                            
  [pool_tdata]    /dev/sdc1(1)                             
  [pool_tmeta]    /dev/sdf1(0)                             
  snap                                                



Marking verified with:

lvm2-2.02.100-1.el6.x86_64
Comment 6 errata-xmlrpc 2013-11-21 18:17:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1704.html

Note You need to log in before you can comment on or make changes to this bug.