This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 861231 - [abrt] liferea-1.8.8-1.fc17: Process /usr/bin/liferea was killed by signal 11 (SIGSEGV)
[abrt] liferea-1.8.8-1.fc17: Process /usr/bin/liferea was killed by signal 11...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
abrt_hash:b4f46886a75e6291b95341ae379...
:
: 875561 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 17:31 EDT by Ivan Cooper
Modified: 2012-11-23 02:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 22:12:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (950 bytes, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details
File: environ (1.43 KB, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details
File: backtrace (25.51 KB, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details
File: cgroup (128 bytes, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details
File: maps (53.97 KB, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details
File: dso_list (8.56 KB, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details
File: var_log_messages (453 bytes, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details
File: open_fds (1.35 KB, text/plain)
2012-09-27 17:31 EDT, Ivan Cooper
no flags Details

  None (edit)
Description Ivan Cooper 2012-09-27 17:31:04 EDT
Description of problem:
This problem appears to be reproducible. Tried several times with different feeds.

STEPS TO REPRODUCE:
1. Set up Liferea with Google Reader synchronization
2. Right click on any Google Reader feed and select "Delete"

EXPECTED:
* feed is deleted
* program continues to operate

ACTUAL:
* feed disappears from tree view
* liferea crashes 1 or 2 seconds later
* feed was not actually removed


Version-Release number of selected component:
liferea-1.8.8-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        liferea
crash_function: google_source_edit_remove_callback
kernel:         3.5.4-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (4 frames)
: #0 google_source_edit_remove_callback at google_source_edit.c
: #1 google_source_edit_action_complete at google_source_edit.c
: #2 update_process_result_idle_cb at update.c
: #7 gtk_main at gtkmain.c
Comment 1 Ivan Cooper 2012-09-27 17:31:06 EDT
Created attachment 618301 [details]
File: core_backtrace
Comment 2 Ivan Cooper 2012-09-27 17:31:08 EDT
Created attachment 618302 [details]
File: environ
Comment 3 Ivan Cooper 2012-09-27 17:31:09 EDT
Created attachment 618303 [details]
File: limits
Comment 4 Ivan Cooper 2012-09-27 17:31:11 EDT
Created attachment 618304 [details]
File: backtrace
Comment 5 Ivan Cooper 2012-09-27 17:31:12 EDT
Created attachment 618305 [details]
File: cgroup
Comment 6 Ivan Cooper 2012-09-27 17:31:14 EDT
Created attachment 618306 [details]
File: maps
Comment 7 Ivan Cooper 2012-09-27 17:31:15 EDT
Created attachment 618307 [details]
File: dso_list
Comment 8 Ivan Cooper 2012-09-27 17:31:16 EDT
Created attachment 618308 [details]
File: var_log_messages
Comment 9 Ivan Cooper 2012-09-27 17:31:18 EDT
Created attachment 618309 [details]
File: open_fds
Comment 10 Ivan Cooper 2012-09-27 19:18:43 EDT
One correction regarding actual behavior:

At first when I restarted Liferea after a crash, the feed I had tried to delete was still visible.  However I think I didn't wait long enough for it to refresh with Google.  After refreshing the Google feed list, it turns out that the feeds actually had been deleted successfully from my Google account before Liferea crashed.
Comment 11 Florian Wallner 2012-11-05 03:20:43 EST
I use Google Reader as a source. When I tried to unsubscribe from a feed using the context-menu entry 'delete' liferea crashed.

backtrace_rating: 4
Package: liferea-1.8.8-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Yanko Kaneti 2012-11-12 02:18:43 EST
*** Bug 875561 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2012-11-13 09:33:51 EST
liferea-1.8.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/liferea-1.8.10-2.fc17
Comment 14 Fedora Update System 2012-11-13 09:35:22 EST
liferea-1.8.10-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/liferea-1.8.10-2.fc18
Comment 15 Fedora Update System 2012-11-14 21:49:06 EST
Package liferea-1.8.10-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liferea-1.8.10-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18254/liferea-1.8.10-2.fc17
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-11-22 22:12:53 EST
liferea-1.8.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-11-23 02:57:45 EST
liferea-1.8.10-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.