Bug 861289 - glusterd crash while testing quorum functionality
glusterd crash while testing quorum functionality
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Pranith Kumar K
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 01:07 EDT by Sachidananda Urs
Modified: 2013-09-23 18:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:33:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash report (1.89 MB, application/x-tar)
2012-09-28 01:07 EDT, Sachidananda Urs
no flags Details

  None (edit)
Description Sachidananda Urs 2012-09-28 01:07:17 EDT
Created attachment 618410 [details]
Crash report

Description of problem:
While testing quorum functionality for a 2x2 setup glusterd crashed when glusterds on couple of servers were killed.


Steps to Reproduce:
1. Keep some I/O happening on the client.
2. kill couple of glusterd servers.
3. run a few gluster volume commands on the servers where glusterd is still running.
  
Additional info:
Attached logs, core and sosreport.
Comment 2 Pranith Kumar K 2012-09-28 02:50:40 EDT
The issue happens on executing gluster volume set help because of the special handling given to that command in op-sm. Will be sending the patch.
Comment 3 Scott Haines 2013-09-23 18:33:27 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.