Bug 861309 - USB disks ignore configured address
USB disks ignore configured address
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 985166
  Show dependency treegraph
 
Reported: 2012-09-28 02:17 EDT by Vladislav Bogdanov
Modified: 2013-07-16 21:48 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 985166 (view as bug list)
Environment:
Last Closed: 2013-01-06 15:14:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Honor <address/> node for USB disks with qemu (467 bytes, text/plain)
2012-09-28 02:18 EDT, Vladislav Bogdanov
no flags Details
Allow USB disks to be connected to USB hub (qemu) (1.32 KB, text/plain)
2012-09-28 02:19 EDT, Vladislav Bogdanov
no flags Details
Allow USB disks to be connected to USB hub (qemu) (fix tests) (188.48 KB, text/plain)
2012-09-28 02:20 EDT, Vladislav Bogdanov
no flags Details

  None (edit)
Description Vladislav Bogdanov 2012-09-28 02:17:52 EDT
Description of problem:
If one has USB disks configured for domain with explicit <address/>, libvirtd ignores that node when building qemu command line. So, disk are connected to the first free USB port implicitly by qemu.
That breaks other USB devices which have explicit <address/> - ports they should be connected to may be already occupied by disks.
I attach patch (libvirt-0.10.2-qemu-usb-storage-address.patch) to fix that.

Then, with that patch applied, if one has USB disk connected to the USB hub, qemu fails to start, because it does not know anything about hubs yet (when parsing disks).

I attach patch to fix that (libvirt-0.10.2-qemu-early-usb-hub-append.patch) together with fixes to tests suite (libvirt-0.10.2-qemu-early-usb-hub-append-tests-fix.patch)

Version-Release number of selected component (if applicable):
libvirt-0.10.2
qemu-1.2.0
Comment 1 Vladislav Bogdanov 2012-09-28 02:18:45 EDT
Created attachment 618424 [details]
Honor <address/> node for USB disks with qemu
Comment 2 Vladislav Bogdanov 2012-09-28 02:19:39 EDT
Created attachment 618425 [details]
Allow USB disks to be connected to USB hub (qemu)
Comment 3 Vladislav Bogdanov 2012-09-28 02:20:27 EDT
Created attachment 618426 [details]
Allow USB disks to be connected to USB hub (qemu) (fix tests)

Patch is against 0.10.2
Comment 4 Cole Robinson 2012-10-21 17:05:33 EDT
Awesome Vladislav, thanks for the patches! They look good to me but we do all our patch review on the upstream mailing list.

Can you send these to libvirt-list@redhat.com ? Following the git workflow here is preferred:

http://libvirt.org/hacking.html#patches
Comment 5 Cole Robinson 2012-10-27 13:01:50 EDT
Patches posted upstream:

https://www.redhat.com/archives/libvir-list/2012-October/msg01551.html
Comment 6 Fedora Update System 2012-12-09 20:15:01 EST
libvirt-0.9.11.8-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.8-1.fc17
Comment 7 Fedora Update System 2012-12-16 15:03:40 EST
libvirt-0.9.11.8-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.8-2.fc17
Comment 8 Fedora Update System 2013-01-03 02:24:12 EST
libvirt-0.9.11.8-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.