Bug 861332 - Properly reset usb channels after non-seamless migration
Properly reset usb channels after non-seamless migration
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 04:00 EDT by Hans de Goede
Modified: 2013-02-21 03:49 EST (History)
5 users (show)

See Also:
Fixed In Version: spice-gtk-0.14-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:49:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2012-09-28 04:00:52 EDT
Once bug 861331 is fixed it will be possible to migrate vms with usb-redir devices without using seamless migration. Currently spice-gtk gets confused about the USB state after a non-seamless (switch-host or semi-seamless) migration. It thinks a device is still redirected, un-redirecting and redirecting it again won't restore vm access to the device.

I've posted 2 patches upstream fixing this:
http://lists.freedesktop.org/archives/spice-devel/2012-September/011033.html
http://lists.freedesktop.org/archives/spice-devel/2012-September/011034.html

I believe we should fix this for 6.4 too.
Comment 5 errata-xmlrpc 2013-02-21 03:49:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0343.html

Note You need to log in before you can comment on or make changes to this bug.