Bug 861350 - firefox doesn't work properly without pulseaudio running
firefox doesn't work properly without pulseaudio running
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 05:58 EDT by Toni Willberg
Modified: 2013-01-04 07:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-04 07:09:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2012-09-28 05:58:47 EDT
Description of problem:
 Firefox UI doesn't work properly if pulseaudio process is not running.


Version-Release number of selected component (if applicable):
 firefox-10.0.7-1.el6_3.x86_64

How reproducible:
 always

Steps to Reproduce:
1. kill or don't install pulseaudio
2. start firefox as normal user
3. click "Bookmarks"
  
Actual results:
 the menu opens quickly

Expected results:
 menu opens only after 20-30 seconds delay

Additional info:
 After starting "pulseaudio" as the same user Firefox's menus started responding properly.

I noticed this by first installing a server with X/GNOME, and later did yum groupinstall for graphical environment. 

A server environment shouldn't require audio, and Firefox is sometimes needed for configuring servers such as RHEV-M.
Comment 2 RHEL Product and Program Management 2012-12-14 03:04:08 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Toni Willberg 2013-01-04 06:57:14 EST
It seems that firefox starts pulseaudio if it's not running. However it will fail if pulseaudio is not installed.

I'd say the bug is real; it's very common to install server first without X, and then later install Firefox and X dependencies.

Maybe this could be fixed by adding pulseaudio to Firefox dependencies?
Comment 5 Martin Stransky 2013-01-04 07:06:10 EST
I removed pulseaudio from my rhel6 virtual box (by yum remove pulseaudio) and reboot the box and firefox works fine w/o any problem. So I don't see the problem you're talking about. I also removed a soundcard from the virtual box and it does not affect FF either.
Comment 6 Martin Stransky 2013-01-04 07:08:51 EST
And I don't see any dupes for this bug...so it still looks like a WONTFIX or WORKSFORME.
Comment 7 Toni Willberg 2013-01-04 07:09:54 EST
ok, maybe I had some other problem on the server earlier. Lets close this then. Thanks!

Note You need to log in before you can comment on or make changes to this bug.