Bug 86137 - DB/2 instance fails to start
DB/2 instance fails to start
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-14 13:17 EST by G.S. Link
Modified: 2016-11-24 10:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-05 04:44:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.S. Link 2003-03-14 13:17:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
On both upgrade from 8.0 and fresh install DB/2 instances fail to start.  Two
scenarios were tried. A correctly running 8.0 system was upgraded.  Neither the
DB instance nor the Admin instance would start.  Both returned generic failure
messages on start.  Then a fresh install was tried.  DB/2 appeared to install
correctly but the installer could not start any created instances. This problem
does not appear on 8.0 only on Phoebe.

Version-Release number of selected component (if applicable):
DB/2 EE 7.2 fp.8

How reproducible:
Always

Steps to Reproduce:
1.Install DB/2 EE and request creation of an instance or upgrade a running system.
2.
3.
    

Actual Results:  Instance creation failed or would not start if upgrade.

Expected Results:  DB/2 should run

Additional info:
Comment 1 Arjan van de Ven 2003-03-14 13:19:36 EST
could you try to get more information on this?
can it be straced?
Comment 2 G.S. Link 2003-03-18 10:02:51 EST
I am not permitted to spend the resources to find a bug such as this.  If you
can trace the DB/2 source you should find the problem.  That is going to need to
be done through IBM.  Any problem report to IBM Toronto is going to come back
that Phoebe is not supported and the problem belongs to Red Hat.  I have
reported several bugs and I suspect all of them are related.  If Red Hat
requests help from IBM there should not be a problem but even an strace is
probably not going to show what is necessary.  I did try installing a 2.4.20
kernel in 8.0 with NO problems so I do not believe this is a kernel problem. 
The presence or absence of remote instances also made no difference.  In setting
up DB/2 you need to restrict the use of stacks to an earlier model in your Java
jre or the control center will not run.  In addition you need to increase stack
size or you will not be able to do a backup.  Both of these could be problems
but the fresh install was done before a jre was loaded or the stack size was set
so I doubt if this is a problem.  The most common source of this kind of problem
is usually in TCP/IP.  That is where I would look first.  I also have not tried
DB/2 ver 8.  If this failure persists there IBM will provide help to Red Hat. 
We figure that based on past bugs that finding this one will probably cost about
$5000 in time and resources.  My company refuses to foot the bill.
Comment 3 Arjan van de Ven 2003-03-18 12:09:52 EST
java related stuff is usually a glibc interaction
Comment 4 G.S. Link 2003-03-20 14:48:41 EST
DB/2 is designed to run without any Java at all and only the Control Center
actually requires a jre.  Currently the only jre that works is the IBM 1.1.8 jre
as that has added classes that are not in the Blackdown version.I doubt this has
anything to do with Java at all but on a bug report I try to eliminate as many
problems as I can within the budget.
Comment 5 Ulrich Drepper 2003-10-03 04:53:41 EDT
Well, if you still see the problem and you cannot help debugging and you cannot
get IBM to look at this, there is not much we can do.  We cannot debug 3rd party
apps, especially none of the size of DB2.
Comment 7 Bob Johnson 2003-10-03 12:59:00 EDT
We looked at this and it is an unsupported configuration.

We see that the customer had upgraded to RH 9.

DB2 v7 and v8 does not support RH 9 (issues with libc for v7, and with
java for v8).

Since the error message the customer got is not included in the bug
record we do not have enough info
to respond to what the exact problem in this instance.

Please direct this customer to use RHEL.
Comment 8 Ulrich Drepper 2003-10-05 04:44:04 EDT
According to IBM, not a supported combination.  RHEL is the supported Red hat
platform for deployment of DB2.
Comment 9 G.S. Link 2003-10-07 10:07:07 EDT
This bug has now been documented by IBM and the workaround is to implement an
LD_ASSUME_KERNEL=2.2.5 statement.  It appears that even DB/2 8.1 will not run
with the new kernel.  Consider the problem closed.

Note You need to log in before you can comment on or make changes to this bug.