Bug 861413 - system-config-printer.py should not be executable
system-config-printer.py should not be executable
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
17
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 10:20 EDT by Michal Nowak
Modified: 2012-10-01 10:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 10:03:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2012-09-28 10:20:08 EDT
Description of problem:

/usr/share/system-config-printer/system-config-printer.py is currently executable file:

    -rwxr-xr-x. /usr/share/system-config-printer/system-config-printer.py

and because of this zeitgeist-datahub is looking for it's desktop file (which does not exist) and eventually fails with

    ** (process:1256): WARNING **: recent-manager-provider.vala:125: Desktop file for system-config-printer.py was not found

in ~/.xsession-error file.

Since s-c-printer is being executed via /usr/bin/s-c-printer or via it's desktop file, s-c-printer.py does not need executable bit.

Version-Release number of selected component (if applicable):

system-config-printer-1.3.9-1.fc17.x86_64
Comment 1 Jiri Popelka 2012-10-01 08:51:47 EDT
Seems it needs to be executable:

# chmod -x /usr/share/system-config-printer/system-config-printer.py

# system-config-printer
/bin/system-config-printer: line 3: /usr/share/system-config-printer/system-config-printer.py: Permission denied
/bin/system-config-printer: line 3: exec: /usr/share/system-config-printer/system-config-printer.py: cannot execute: Permission denied
Comment 2 Tim Waugh 2012-10-01 10:03:32 EDT
Yes, the /usr/bin script executes it.

Note You need to log in before you can comment on or make changes to this bug.