Bug 861418 - the 'Image UUID' label used in the image details page seams meaningless while the real image ID is missing
the 'Image UUID' label used in the image details page seams meaningless while...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
medium Severity low
: beta4
: ---
Assigned To: Tzu-Mainn Chen
Giulio Fidente
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 10:32 EDT by Giulio Fidente
Modified: 2013-05-01 17:17 EDT (History)
7 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Bug Fix
Doc Text:
The 'Image UUID' label used in the image details page did not contain the real Image ID and appeared meaningless. This bug fix displays the useful Image UUID information on the details page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:22:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio Fidente 2012-09-28 10:32:22 EDT
the 'Image UUID' label used in the image details page seams meaningless, the real image ID isn't displayed instead.

the image ID should be unique across builds and target providers; that is also the value needed by audrey in the depolyable files, but is missing from the page

as a reference, from the commandline tool one can list the following:

aeolus-image list --images
aeolus-image list --images --environment $envenvironment
aeolus-image list --builds $image_id
aeolus-image list --targetimages $build_id
aeolus-image list --providerimages $target_id
Comment 1 Angus Thomas 2012-10-03 10:36:31 EDT
The "Image UUID" us actually our UUID for the Provider image. Note that is different to the "Cloud Resource Provider's Image ID ". The latter is the ID number assigned by the provider to the copy of the image which has been pushed. e.g. the Amazon AMI ID.

I suggest that we remove the "Image UUID", since it is no easy to describe its purpose, it is available from the CLI, and, in the absence of the ability to delete the images, there's not a great deal that can be done with it.

Once it is removed, we can add a new field, Labelled "Image ID", in the "Properties" field, which currently contains "Cloud: <cloud name>" That field should display the Image Id, which is currently only available in the URL for the page, and which is the ID which is most likely to be used in application blueprints etc,,
Comment 4 Tzu-Mainn Chen 2012-10-03 16:33:20 EDT
Pushed to master/1.1:

commit e7f468765bac0dbdc4c398e6cc6e50f338c21473
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Wed Oct 3 15:11:27 2012 -0400

    BZ861418 display useful image uuid information on details page
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit 0eac62b3748e537c6d99241e23441b179083aaa7)
Comment 6 Giulio Fidente 2012-10-10 12:17:08 EDT
works for me
Comment 8 errata-xmlrpc 2012-12-04 10:22:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.