This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 861419 - Conflict between hunspell-en-US and hunspell-en when doing yum groupinstall 'Basic X Windows'
Conflict between hunspell-en-US and hunspell-en when doing yum groupinstall '...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hunspell (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 10:34 EDT by Stephen Gordon
Modified: 2012-09-28 11:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 11:36:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-09-28 10:34:57 EDT
Description of problem:

When I run "yum install 'Basic X Windows" on a fresh (minimal) F18 Alpha installation the transaction ends with:

Transaction Check Error:
  file /usr/share/myspell/en_US.dic from install of hunspell-en-US-0.20110318-8.fc18.noarch conflicts with file from package hunspell-en-0.20110318-6.fc18.noarch

Not sure if this is an issue with hunspell packaging or the list of packages included in the 'Basic X Windows' group needs to change - filing against hunspell in the first instance to get the packager's opinion/clarification.
Comment 1 Stephen Gordon 2012-09-28 10:54:38 EDT
OK. I think cinnamon is involved here as well. Effectively the order of operations was:

- Minimal Fedora install.
- yum install cinnamon, which appears to drag in hunspell-en
- Doh! I need an X server!
- yum groupinstall 'Basic X windows', which appears to drag in hunspell-en-US

Not sure whose dep or conflict is right or wrong in the above scenario.
Comment 2 Stephen Gordon 2012-09-28 11:01:52 EDT
I removed all hunspell* packages (and therefore cinnamon) and tried the groupinstall again. Still fails. Looks like the 'Basic X windows' group either directly or indirectly attempts to install both hunspell-en and hunspell-en-US.
Comment 3 Caolan McNamara 2012-09-28 11:13:59 EDT
hunspell-en-US-0.20110318-8.fc18.noarch
hunspell-en-0.20110318-6.fc18.noarch

hmm, the version numbers are different, but both should be 0.20110318-8.
Comment 4 Stephen Gordon 2012-09-28 11:23:10 EDT
Could just be a stale mirror interfering, I was getting the same behaviour yesterday though so waited a day and ran 'yum clean all' before trying again.
Comment 5 Stephen Gordon 2012-09-28 11:36:27 EDT
Confirmed, I ran yum clean all yet again. I then:

# yum group install 'Basic X windows'
# yum install cinnamon
# rpm -qa | grep hunspell
hunspell-1.3.2-8.fc18.x86_64
hunspell-en-US-0.20110318-8.fc18.noarch
hunspell-en-GB-0.20110318-8.fc18.noarch
hunspell-en-0.20110318-8.fc18.noarch

So I now appear to be getting the correct version. I assume one or more mirrors were/are still catching up to the latest push of one of these packages. Closing notabug.

Note You need to log in before you can comment on or make changes to this bug.