Bug 86142 - status() in /etc/rc.d/init.d/functions does not distinguish daemons properly
status() in /etc/rc.d/init.d/functions does not distinguish daemons properly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-14 15:34 EST by Boris Folgmann
Modified: 2014-03-16 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 21:28:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Boris Folgmann 2003-03-14 15:34:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2; MultiZilla v1.1.32
final) Gecko/20021207

Description of problem:
status seems to call pidof daemon_file_name instead of pidof
daemon_path/daemon_file_name


Version-Release number of selected component (if applicable):
initscripts-6.67-1

How reproducible:
Always

Steps to Reproduce:
1. /usr/cyrus/bin/master is running 
2. /usr/libexec/postfix/master is NOT running
3. Try /etc/init.d/postfix status
  

Actual Results:  postfix is reported as running!

Expected Results:  postfix should be reported as not running, because
/usr/cyrus/bin/master is not /usr/libexec/postfix/master

Additional info:

I suggest to save the pid to a file when the daemon is started and then do
something like ps|grep pid to check if the exact same instance is still running.
Comment 1 Bill Nottingham 2003-09-03 21:28:19 EDT
I believe this is fixed in current initscripts, such as those shipped with Red
Hat Linux 9.

Note You need to log in before you can comment on or make changes to this bug.