Bug 861420 - Red Hat Enterprise Virtualization (rhev-3.0) 150.pem product certs are missing from subscription-manager-migration-data
Red Hat Enterprise Virtualization (rhev-3.0) 150.pem product certs are missin...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-28 10:37 EDT by John Sefler
Modified: 2013-01-08 02:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:28:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-09-28 10:37:46 EDT
Description of problem:
I suspect rel-eng regenerated their cdn/product-baseline.json, and now it looks like the subscription-manager-migration-data needs to be regenerated to pick up product certs for the following:

> 201209281017:04.455 - WARNING: CDN product cert [git://git.app.eng.bos.redhat.com/rcm/rcm-metadata.git] /product_ids/rhev-3.0/product-x86_64-4d1f929972d7-150.pem was NOT found among the current migration product certs.  It is probably a new product cert generated by release engineering and therefore subscription-manager-migration-data needs a regeneration. (com.redhat.qe.sm.cli.tests.MigrationTests.VerifyMigrationProductCertsMatchThoseFromRhnDefinitions_Test)
> 201209281017:04.456 - WARNING: CDN product cert [git://git.app.eng.bos.redhat.com/rcm/rcm-metadata.git] /product_ids/rhev-3.0/product-i386-b44761d71270-150.pem was NOT found among the current migration product certs.  It is probably a new product cert generated by release engineering and therefore subscription-manager-migration-data needs a regeneration. (com.redhat.qe.sm.cli.tests.MigrationTests.VerifyMigrationProductCertsMatchThoseFromRhnDefinitions_Test)



Version-Release number of selected component (if applicable):
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.4-1.el5


How reproducible:


Steps to Reproduce:
[root@rhsm-accept-rhel5 ~]# rpm -ql subscription-manager-migration-data | grep 150.pem
[root@rhsm-accept-rhel5 ~]#

^^^ EXPECTED GREP TO FIND 
product-x86_64-4d1f929972d7-150.pem
product-i386-b44761d71270-150.pem


[root@rhsm-accept-rhel5 ~]# grep rhel-x86_64-rhev-mgmt-agent-5 /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
[root@rhsm-accept-rhel5 ~]#
^^^ EXPECTED GREP TO FIND A MAPPING FOR CHANNELS MATCHING rhel-x86_64-rhev-mgmt-agent-5*
Comment 1 John Sefler 2012-09-28 10:42:32 EDT
Dennis
In the following snippet from [rcm/rcm-metadata.git]/cdn/product-baseline.json, I do not see any i386 channels for product 150, yet there is one located in [rcm/rcm-metadata.git]/product_ids/rhev-3.0/product-i386-b44761d71270-150.pem.   Something seems askew.  Please confirm.

Additional info:

25217         "Name": "Red Hat Enterprise Virtualization", 
25218         "Product ID": "150", 
25219         "RHN Channels": [
25220             "rhel-x86_64-rhev-mgmt-agent-5", 
25221             "rhel-x86_64-rhev-mgmt-agent-5-beta", 
25222             "rhel-x86_64-rhev-mgmt-agent-6", 
25223             "rhel-x86_64-rhev-mgmt-agent-6-beta", 
25224             "rhel-x86_64-rhev-mgmt-agent-6-beta-debuginfo", 
25225             "rhel-x86_64-rhev-mgmt-agent-6-debuginfo", 
25226             "rhel-x86_64-server-6-rhevh", 
25227             "rhel-x86_64-server-6-rhevh-beta", 
25228             "rhel-x86_64-server-6-rhevh-beta-debuginfo", 
25229             "rhel-x86_64-server-6-rhevh-debuginfo", 
25230             "rhel-x86_64-server-6-rhevm-3", 
25231             "rhel-x86_64-server-6-rhevm-3-beta", 
25232             "rhel-x86_64-server-6-rhevm-3-beta-debuginfo", 
25233             "rhel-x86_64-server-6-rhevm-3-debuginfo"
25234         ]
Comment 2 Dennis Gregorovic 2012-09-28 10:44:58 EDT
At one point there were i386 content sets in the 150 product, but they got moved out.
Comment 3 RHEL Product and Program Management 2012-09-28 10:46:10 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Alex Wood 2012-10-01 16:44:33 EDT
commit 0ad558b17e0ae9c23d310b115ed967b13998e561
Author: Alex Wood <awood@redhat.com>
Date:   Mon Oct 1 14:05:02 2012 -0400

    861420: Add mapping and certificates for RHEV 3.0.
Comment 6 John Sefler 2012-10-08 17:12:08 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.6-1.el5

[root@jsefler-rhel59 ~]# rpm -ql subscription-manager-migration-data | grep 150.pem
/usr/share/rhsm/product/RHEL-5/product-x86_64-4d1f929972d7-150.pem

[root@jsefler-rhel59 ~]# grep rhev-mgmt-agent-5 /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-x86_64-rhev-mgmt-agent-5: product-x86_64-4d1f929972d7-150.pem
rhel-x86_64-rhev-mgmt-agent-5-beta: product-x86_64-4d1f929972d7-150.pem

[root@jsefler-rhel59 ~]# grep 150.pem /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-x86_64-rhev-mgmt-agent-5: product-x86_64-4d1f929972d7-150.pem
rhel-x86_64-rhev-mgmt-agent-5-beta: product-x86_64-4d1f929972d7-150.pem


As indicated in comment 2, there are no i386 product certs nor channels for "Red Hat Enterprise Virtualization" and therefore no mappings exist in subscription-manager-migration-data.

Moving to VERIFIED
Comment 8 errata-xmlrpc 2013-01-08 02:28:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0055.html

Note You need to log in before you can comment on or make changes to this bug.