Bug 861442 - dm-thin lacks discard support
dm-thin lacks discard support
Status: CLOSED DUPLICATE of bug 828955
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 11:38 EDT by Neil Wilson
Modified: 2013-01-18 16:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 16:58:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Wilson 2012-09-28 11:38:57 EDT
Description of problem:

dm-thin lacks support for BLKDISCARD in the current kernel version, which means that the partitions only ever grow and they can't be efficiently zeroed.


Version-Release number of selected component (if applicable):

 2.6.32-279.9.1.el6


How reproducible:


Source code notes that discard support is missing in this technology preview.
Comment 2 RHEL Product and Program Management 2012-12-14 03:24:58 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Mike Snitzer 2013-01-18 16:58:31 EST
Discard support has been added to dm-thin in RHEL6.4.

*** This bug has been marked as a duplicate of bug 828955 ***

Note You need to log in before you can comment on or make changes to this bug.