Bug 861446 - Support "pass though" SQL commands to sources
Support "pass though" SQL commands to sources
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: EDS (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: 5.3.1
Assigned To: jolee
Filip Nguyen
:
Depends On:
Blocks: 880831 857488
  Show dependency treegraph
 
Reported: 2012-09-28 11:43 EDT by Rick Wagner
Modified: 2013-12-16 18:35 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, there was no easy mechanism to allow a source specific query to be submitted to the runtime engine. Users needed to resort to user defined functions which can be unnecessarily complex. Source specific queries (or "native queries") can now be set in Teiid Designer. The runtime engine will then use this native query as an inline view instead of the respective table name within a FROM clause.
Story Points: ---
Clone Of:
: 880831 (view as bug list)
Environment:
Last Closed: 2013-07-09 11:39:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-669 Major Closed Support "pass though" SQL commands to sources 2016-05-10 05:23 EDT

  None (edit)
Description Rick Wagner 2012-09-28 11:43:49 EDT
* This is the Product tracker for Community JIRA TEIID-669 *

Per the EDS call 09/28/12, we should produce this feature, demonstrate it to a customer that needs it, and include it in the next available EDS Roll up after.



Currently there is no mechanism in Teiid, when a query is submitted to a runtime engine that is passed through the query engine unadulterated and unmodified and submitted directly to a source connector. All queries are parsed, optimized, re-written. Some times this limits the functionality in Teiid, when a user would like to execute a query that is very "source" specific. For example Oracle supports lots of Oracle specific functions that are not supported by the SQL spec, to support execution of these in Teiid user need to resort to UDF, which is cumbersome and involves modelling.
Another benefit of this is also to pass DDL to sources, currently since Teiid does not support DDL, this is not possible at all.
Comment 2 JBoss JIRA Server 2012-10-04 08:58:52 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-669 to Resolved
Comment 3 JBoss JIRA Server 2012-10-04 08:58:52 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-669

with TEIID-2176, TEIID-2177, and the existing native-query support I'm marking this issue as resolved as to limit what it covers.

New issues can be created to cover incremental improvements or some form of a pass through query mode directly from the client.
Comment 5 JBoss JIRA Server 2012-10-26 12:54:25 EDT
Ramesh Reddy <rareddy@jboss.org> made a comment on jira TEIID-669

JLee, I thought the only changes we are going to do for EDS 5.3 was in the JBDS which are going in their rollup. The extension properties for native query for relational sources is already in the 5.3. These TEIID-2176, TEIID-2177 JIRAs expand the native query support to other sources and also provide native procedure support which we are not approved for 5.3
Comment 10 jolee 2012-10-31 14:48:59 EDT
re-adding as a blocker as engineering has found an issue.  backport to follow (soon).
Comment 11 jolee 2012-10-31 17:32:02 EDT
Committed r4525 to https://svn.jboss.org/repos/teiid/branches/7.7.x
Comment 12 Filip Nguyen 2012-11-15 12:55:54 EST
Verified in 5.3.1 ER1 with JBDS SOA/BRMS tooling 5.0.1 (released on CSP 7th November).

It is possible to set the native query in Teiid Designer in source model. The native query will be then embedded as inline view in FROM clause.
Comment 13 JBoss JIRA Server 2013-12-16 18:35:40 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-669 to Closed

Note You need to log in before you can comment on or make changes to this bug.