This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 861452 - webkitgtk-1.10.0-1 not built with $RPM_OPT_FLAGS
webkitgtk-1.10.0-1 not built with $RPM_OPT_FLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: webkitgtk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2012-09-28 12:07 EDT by Ville Skyttä
Modified: 2013-04-01 10:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-03 13:24:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2012-09-28 12:07:05 EDT
webkitgtk-1.10.0-1 is not built with $RPM_OPT_FLAGS:

http://kojipkgs.fedoraproject.org//packages/webkitgtk/1.10.0/1.fc19/data/logs/x86_64/build.log

1.8.3-1 did not have this problem.
Comment 1 Kevin Fenzi 2012-09-28 12:22:37 EDT
Thats because it won't build with the default RPM_OPT_FLAGS. ;) 

It creates a >4GB ar archive that ar barfs on. 

From the comment in the spec: 

# Build with -g1 on all platforms to avoid running into 4 GB ar format limit
# https://bugs.webkit.org/show_bug.cgi?id=91154
%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')

So, not sure what else we can do here until upstream splits things up more.
Comment 2 Kalev Lember 2012-12-10 18:52:34 EST
The issue with 4 GB ar archives is now fixed upstream in webkitgtk 1.10.2 by splitting the library up into smaller chunks.

But now the builds with full -g are running into another issue: in koji, during the final ld linking step the linker gets killed by the OOM killer. So unfortunately, Fedora webkitgtk / webkitgtk3 1.10.2-1 buids are still done with -g1.
Comment 3 Kevin Fenzi 2013-02-02 22:41:32 EST
With the recent rearrangment of the builders to have more memory this no longer seems to be the problem. I am going to revert this now. ;) 

Kalev: Would you like to do this for webkitgtk3? or would you like me to?
Comment 4 Kalev Lember 2013-02-03 07:19:27 EST
Awesome. Sure, please go ahead with webkitgtk3 as well.
Comment 5 Kevin Fenzi 2013-02-03 13:24:04 EST
Sadly, webkitgtk3 still fails. ;( 

/usr/bin/ld: failed to set dynamic section sizes: Memory exhausted
collect2: error: ld returned 1 exit status

So, I guess we keep it in webkitgtk3 for now... when webkitgtk moves to the newer version it may also have to do this. ;( 

Hopefully a better solution can be found upstream.

Note You need to log in before you can comment on or make changes to this bug.