Bug 861471 - the deployable parameter's values passed via webui are not received by the audrey agent on the client
the deployable parameter's values passed via webui are not received by the au...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity high
: beta4
: ---
Assigned To: Jan Provaznik
Giulio Fidente
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 13:57 EDT by Giulio Fidente
Modified: 2012-12-04 10:22 EST (History)
7 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Bug Fix
Doc Text:
Application Blueprint parameter values passed via UI were not received by Audrey Agent on the client. The values received by Audrey Agent were defaults specified in the Application Blueprint. This bug fix saves the changed launch parameters. The values received by the Audrey Agent are now the ones specified in the UI.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:22:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is the test deployable ilfe used to reproduce the error (859 bytes, text/xml)
2012-10-02 10:49 EDT, Giulio Fidente
no flags Details

  None (edit)
Description Giulio Fidente 2012-09-28 13:57:21 EDT
Description of problem:
the deployable parameter's values passed via webui are not received by the audrey agent on the client, which receives instead the default values set in the deployable

Version-Release number of selected component (if applicable):
aeolus-conductor-0.13.14-1.el6cf

Steps to Reproduce:
1. deploy an application using the test deployable attached
2. wait for the audrey agent to start
3. check the values received in /var/log/audrey.log
  
Actual results:
the values received by the audrey agent are the defaults specified in the deployable

Expected results:
the values received by the audrey agent are the ones specified in the conductor webui
Comment 1 Giulio Fidente 2012-09-29 16:37:08 EDT
to add some more details to the bug report, it looks like the parameter's values inserted via webui in conductor are not passed to the configserver

in the aeolus-configserver.log the values shown are the ones provided as default in the deployable

on top of that, deployables which contain parameters with no default values set in the deployable file, _cannot_ be deployed and an error in webui appears
Comment 2 Giulio Fidente 2012-10-02 10:49:30 EDT
Created attachment 620327 [details]
this is the test deployable ilfe used to reproduce the error
Comment 3 Jan Provaznik 2012-10-03 09:01:55 EDT
a patch for this is waiting for review:
https://github.com/aeolusproject/conductor/pull/92
Comment 4 Matt Wagner 2012-10-03 14:10:15 EDT
See also: https://github.com/aeolusproject/conductor/pull/94
Comment 5 Jan Provaznik 2012-10-04 07:16:43 EDT
hopefully final version of the patch is: https://github.com/aeolusproject/conductor/pull/96
Comment 6 Jan Provaznik 2012-10-04 10:49:08 EDT
pushed to 1.1 branch, commit: d1eb8b92d22484658b75a246f30d8b3ebbb223dc
Comment 8 Giulio Fidente 2012-10-10 13:11:59 EDT
works for me
Comment 10 errata-xmlrpc 2012-12-04 10:22:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.