Bug 861511 - External sound card (USB) does not play sound under kernel 3.5.4-1
External sound card (USB) does not play sound under kernel 3.5.4-1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 17:34 EDT by Rumi
Modified: 2013-03-12 15:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 15:48:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 48051 None None None 2012-10-01 11:38:48 EDT

  None (edit)
Description Rumi 2012-09-28 17:34:36 EDT
Description of problem:

Since upgrading to kernel 3.5.4-1, no sound gets played, from any source I tried. All sound settings appear to be correct. When I boot into 3.5.3-1, the sound is present as expected. There is no visible change in sound settings after the boot into the other kernel. 

Version-Release number of selected component (if applicable): Kernel 3.5.4-1


How reproducible: The bug appears after each boot with this kernel version. It does not appear after boot with an older version. 


Steps to Reproduce:
1. Select kernel 3.5.4-1 from the GRUB screen when booting
2. Copy a known-good wav file called mytestfile.wav to the current directory
3. aplay -vv mytestfile.wav
(can also be reproduced with sound from any other source, using any playback software, or with the command  speaker-test -c 2 -t wav)
  
Actual results:

There is no sound audible 
There are no error messages of any kind 
The output of aplay is as expected for this type of file, listing format, bitrate, etc. 

Expected results:
There is sound audible 
There are no error messages

Additional info:

The sound card is model Onkyo Wavio SE-U55SX.

The system is a custom-built desktop setup, based on a i7 930 CPU. 

The settings visible in Phonon, alsamixer and pavucontrol appear correct: nothing is muted, the correct playback device is selected, etc. 

The sound card's model is correctly recognized in /proc/sound/cards. 

The output of sudo lsmod | grep snd is: 
snd_usb_audio         134325  2 
snd_usbmidi_lib        24728  1 snd_usb_audio
snd_hwdep              17650  1 snd_usb_audio
snd_rawmidi            29531  1 snd_usbmidi_lib
snd_seq                64844  0 
snd_seq_device         14136  2 snd_seq,snd_rawmidi
snd_pcm                97292  1 snd_usb_audio
snd_page_alloc         18101  1 snd_pcm
snd_timer              28690  2 snd_pcm,snd_seq
snd                    79242  12 snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_seq_device
soundcore              14491  1 snd

Another user seems to have the same problem with a different sound card model, again USB-based, see http://ask.fedoraproject.org/question/2558/no-sound-after-update-to-kernel-354-1-fedora-17?comment=4581#comment-4581.
Comment 1 Rumi 2012-10-01 11:38:48 EDT
The bug seems to have been submitted in parallel to the Kernel bug tracker by another user, https://bugzilla.kernel.org/show_bug.cgi?id=48051. There seems to be a patch for it, https://lkml.org/lkml/2012/9/27/172, not yet included in any kernel version. Not sure if I should close this one (or if it is indeed the same bug).
Comment 2 Josh Boyer 2013-03-12 15:48:21 EDT
According to the upstream bug, this was fixed in 3.6.

Note You need to log in before you can comment on or make changes to this bug.