Bug 861516 - compute_nodes not being properly updated
compute_nodes not being properly updated
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
1.0 (Essex)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 17:53 EDT by Dan Yocum
Modified: 2013-07-03 22:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-04 13:14:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2012-09-28 17:53:40 EDT
Description of problem:

One of my compute nodes is never receiving new VMs.  The running_vms field has not been updated since several VMs have failed on this node.  This should be updated regularly, not when VMs are started and terminated.

Version-Release number of selected component (if applicable):

Essex

How reproducible:

always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Nikola Dipanov 2013-01-04 13:14:26 EST
I am not sure I understand what this bug is about. Resource updates (updatest to the  in Essex are done through notifications and the capacity_notifier needs to be set in the notification_driver flag in the nova.conf as it is not used by default.

Folsom does not have this problem as the resource tracker has been implemented at that time and the tables are updated correctly on every action.

I will close it as not a bug.
Comment 3 Dan Yocum 2013-01-04 18:54:10 EST
What's the correct value to set notification_driver to?  The default is nova.notifier.no_op_notifier.

Thanks
Comment 4 Nikola Dipanov 2013-01-05 08:49:29 EST
The value of the notification_driver if you want the compute_nodes db table to be updated should be:

nova.notifier.capacity_notifier

This makes sense only in Essex - this does not exist in Folsom anymore as the updates are done automatically.

Note You need to log in before you can comment on or make changes to this bug.