This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 861525 - Could not set system timezone in date & time
Could not set system timezone in date & time
Status: CLOSED DUPLICATE of bug 864603
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 19:36 EDT by sangu
Modified: 2012-10-11 22:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 22:26:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2012-09-28 19:36:52 EDT
Description of problem:
$ gnome-control-center datetime

(gnome-control-center:2192): datetime-cc-panel-WARNING **: Timezone '(null)' is unhandled, setting Europe/London as default

/* -> Select Timezone in Date&Time */
(gnome-control-center:2192): datetime-cc-panel-WARNING **: Could not set system timezone: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Version-Release number of selected component (if applicable):
3.6.0-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. $ gnome-control-center datetime
2. Click Unlock
3. Click timezone (like a Asia/Seoul)
  
Actual results:


Expected results:


Additional info:
glibc-2.16-15.fc18.x86_64
systemd-191-2.fc18.x86_64
Comment 1 Matthias Clasen 2012-10-04 20:25:48 EDT
works fine here. is selinux enabled ?
Comment 2 Andrew Gunnerson 2012-10-04 21:09:23 EDT
It's probably related to this: http://lists.freedesktop.org/archives/systemd-devel/2012-September/006643.html

Sending DBus commands to systemd fails for some reason, which is why the timezone can't be set (gnome-control-center uses system'd timedated for the timezone stuff).

Matthias: Does the command "gdbus introspect --system --dest org.freedesktop.timedate1 --object-path /org/freedesktop/timedate1" work?
Comment 3 sangu 2012-10-05 06:18:16 EDT
> works fine here. is selinux enabled ?
Yes, selinux is enabled. 

selinux-policy-3.11.1-32.fc18.noarch

# tail -f /var/log/audit/audit.log
type=USER_AVC msg=audit(1349431940.516:604): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { status } for auid=-1 uid=-1 gid=-1 scontext=system_u:system_r:system_dbusd_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=system  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
type=SERVICE_STOP msg=audit(1349431940.532:605): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
type=SERVICE_START msg=audit(1349431966.276:606): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
type=USER_AVC msg=audit(1349431966.277:607): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { status } for auid=-1 uid=-1 gid=-1 scontext=system_u:system_r:system_dbusd_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=system  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
type=SERVICE_STOP msg=audit(1349431966.299:608): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
type=USER_AUTH msg=audit(1349431975.311:609): pid=10059 uid=0 auid=500 ses=2 subj=unconfined_u:system_r:policykit_auth_t:s0-s0:c0.c1023 msg='op=PAM:authentication acct="root" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
type=USER_ACCT msg=audit(1349431975.316:610): pid=10059 uid=0 auid=500 ses=2 subj=unconfined_u:system_r:policykit_auth_t:s0-s0:c0.c1023 msg='op=PAM:accounting acct="root" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
type=SERVICE_START msg=audit(1349431979.803:611): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
type=USER_AVC msg=audit(1349431979.804:612): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { status } for auid=-1 uid=-1 gid=-1 scontext=system_u:system_r:system_dbusd_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=system  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
type=SERVICE_STOP msg=audit(1349431979.820:613): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
type=SERVICE_START msg=audit(1349432091.003:614): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
type=USER_AVC msg=audit(1349432091.005:615): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { status } for auid=-1 uid=-1 gid=-1 scontext=system_u:system_r:system_dbusd_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=system  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
type=SERVICE_STOP msg=audit(1349432091.013:616): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
type=USER_AUTH msg=audit(1349432132.605:617): pid=10120 uid=0 auid=500 ses=2 subj=unconfined_u:system_r:policykit_auth_t:s0-s0:c0.c1023 msg='op=PAM:authentication acct="root" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
type=USER_ACCT msg=audit(1349432132.609:618): pid=10120 uid=0 auid=500 ses=2 subj=unconfined_u:system_r:policykit_auth_t:s0-s0:c0.c1023 msg='op=PAM:accounting acct="root" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
type=SERVICE_START msg=audit(1349432158.734:619): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
type=USER_AVC msg=audit(1349432158.737:620): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { status } for auid=-1 uid=-1 gid=-1 scontext=system_u:system_r:system_dbusd_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=system  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
type=SERVICE_STOP msg=audit(1349432158.743:621): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
(In reply to comment #1)
Comment 4 Steve Tyler 2012-10-11 13:44:53 EDT
(In reply to comment #1)
> works fine here. is selinux enabled ?

Could be:
Bug 864603 - systemd[1]: SELinux policy denies access. (cannot change timezone from gnome control center)

Does the behavior change after running this?
$ sudo setenforce permissive

Restore with:
$ sudo setenforce enforcing
Comment 5 Andrew Gunnerson 2012-10-11 14:21:41 EDT
(In reply to comment #4)
> (In reply to comment #1)
> > works fine here. is selinux enabled ?
> 
> Could be:
> Bug 864603 - systemd[1]: SELinux policy denies access. (cannot change
> timezone from gnome control center)
> 
> Does the behavior change after running this?
> $ sudo setenforce permissive
> 
> Restore with:
> $ sudo setenforce enforcing

It works fine when SELinux is set to permissive mode.

Here's the relevant part of /var/log/audit/audit.log: http://pastie.org/pastes/5036594/text
Comment 6 Steve Tyler 2012-10-11 14:37:00 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #1)
> > > works fine here. is selinux enabled ?
> > 
> > Could be:
> > Bug 864603 - systemd[1]: SELinux policy denies access. (cannot change
> > timezone from gnome control center)
> > 
> > Does the behavior change after running this?
> > $ sudo setenforce permissive
> > 
> > Restore with:
> > $ sudo setenforce enforcing
> 
> It works fine when SELinux is set to permissive mode.
> 
> Here's the relevant part of /var/log/audit/audit.log:
> http://pastie.org/pastes/5036594/text

Thanks for your report. This bug could probably be reassigned to selinux-policy-targeted. It might be helpful to attach /var/log/messages too.

type=SERVICE_START msg=audit(1349979230.395:430): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=' comm="systemd-timedated" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
type=USER_AVC msg=audit(1349979230.398:431): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  received setenforce notice (enforcing=0)  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
Comment 7 Andrew Gunnerson 2012-10-11 14:49:58 EDT
No problem :) I can't reassign the bug report though because I didn't report it.

Here is /var/log/messages after changing the timezone in permissive mode: http://pastie.org/pastes/5036721/text
Comment 8 Steve Tyler 2012-10-11 15:01:57 EDT
(In reply to comment #7)
> No problem :) I can't reassign the bug report though because I didn't report
> it.
> 
> Here is /var/log/messages after changing the timezone in permissive mode:
> http://pastie.org/pastes/5036721/text

Thanks. I can't either, so here is the next best thing: Bug 864603, Comment 10. :-)
Comment 9 Andrew Gunnerson 2012-10-11 15:16:06 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > No problem :) I can't reassign the bug report though because I didn't report
> > it.
> > 
> > Here is /var/log/messages after changing the timezone in permissive mode:
> > http://pastie.org/pastes/5036721/text
> 
> Thanks. I can't either, so here is the next best thing: Bug 864603, Comment
> 10. :-)

Thanks :) I'm going to downgrade my selinux-policy-targeted package to try to find the last working version.

By the way, selinux-policy-targeted's changelog says "Nov 04 2012" in October :)
Comment 10 Steve Tyler 2012-10-11 15:39:32 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > No problem :) I can't reassign the bug report though because I didn't report
> > > it.
> > > 
> > > Here is /var/log/messages after changing the timezone in permissive mode:
> > > http://pastie.org/pastes/5036721/text
> > 
> > Thanks. I can't either, so here is the next best thing: Bug 864603, Comment
> > 10. :-)
> 
> Thanks :) I'm going to downgrade my selinux-policy-targeted package to try
> to find the last working version.
> 
> By the way, selinux-policy-targeted's changelog says "Nov 04 2012" in
> October :)

selinux-policy is updated frequently:
https://admin.fedoraproject.org/updates/search/selinux-policy

It looks like the changelog was corrected in selinux-policy-3.11.1-36:
https://admin.fedoraproject.org/updates/FEDORA-2012-15934/selinux-policy-3.11.1-36.fc18
http://koji.fedoraproject.org/koji/buildinfo?buildID=359451
Comment 11 Andrew Gunnerson 2012-10-11 16:02:41 EDT
Okay, I downgraded to the earliest version of selinux-policy-targeted present in my /var/log/yum.log (3.11.1-7.fc18.noarch), relabeled my filesystem, regenerated the initramfs (in case it has contains SElinux's xattrs), and changing the timezone still fails.

I'm not sure if it's related, but it also seems that any DBus interaction with systemd fails. Typing "sudo systemctl enable [tab] [tab]" gives me this: http://pastie.org/pastes/5037024/text
Comment 12 Daniel Walsh 2012-10-11 22:26:29 EDT

*** This bug has been marked as a duplicate of bug 864603 ***

Note You need to log in before you can comment on or make changes to this bug.