Bug 861530 - anaconda re-creates existing partition when manual partitioning.
anaconda re-creates existing partition when manual partitioning.
Status: CLOSED DUPLICATE of bug 855976
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 20:43 EDT by Simon Peeters
Modified: 2012-10-01 10:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 10:17:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simon Peeters 2012-09-28 20:43:38 EDT
Description of problem:
Today I installed F18 Alpha on my desktop.
I had one partition (a btrfs partition on sda5) which i wanted to keep (it is my old /home)
I configured everything in manual partitioning, removing my old root(/dev/sda4) and swap(/dev/sda3) and adding new ones.
when i continued the installer i saw a status message about formating /dev/sda3 as btrfs, which I did not ask for (i asked for an ext4 partition and swap).
a quick check with parted confirmed what i was afraid of:

  Anaconda deleted my sda5 and recreated it with the same parameters (size/fs) on sda3 (but of course not the data). without me having asked for a change to this partition.
Comment 1 Chris Lumens 2012-10-01 10:17:37 EDT
I believe this is another manifestation of 855976.

*** This bug has been marked as a duplicate of bug 855976 ***

Note You need to log in before you can comment on or make changes to this bug.