This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 861542 - glusterd: volume status improvements
glusterd: volume status improvements
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
Sachidananda Urs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 01:54 EDT by Sachidananda Urs
Modified: 2013-09-23 18:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.1rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-09-29 01:54:39 EDT
When a process not online, mark its port as N/A or `-'


[root@rhs-client19 ~]# gluster volume status
Status of volume: quo
Gluster process                                         Port    Online  Pid
------------------------------------------------------------------------------
Brick rhs-client19.lab.eng.blr.redhat.com:/home/A       24010   N       N/A
Brick rhs-client20.lab.eng.blr.redhat.com:/home/B       24011   N       N/A
Brick rhs-client23.lab.eng.blr.redhat.com:/home/D       24023   N       N/A
NFS Server on localhost                                 38467   Y       20870
Self-heal Daemon on localhost                           N/A     Y       20876
NFS Server on rhs-client20.lab.eng.blr.redhat.com       38467   Y       3047
Self-heal Daemon on rhs-client20.lab.eng.blr.redhat.com N/A     Y       3155
NFS Server on rhs-client23.lab.eng.blr.redhat.com       38467   Y       25787
Self-heal Daemon on rhs-client23.lab.eng.blr.redhat.com N/A     Y       25793
 

[root@rhs-client19 ~]# telnet localhost 24010
Trying ::1...
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
Comment 2 Krutika Dhananjay 2012-10-09 04:33:00 EDT
http://review.gluster.org/#change,4048
Comment 3 Vijay Bellur 2012-10-31 02:08:03 EDT
CHANGE: http://review.gluster.org/4048 (cli: Mark port as N/A in volume status when process is not online) merged in master by Vijay Bellur (vbellur@redhat.com)
Comment 4 Sachidananda Urs 2012-11-19 05:59:48 EST
Is this part of 3.4.0qa2? Since I see the bug still persists in the latest 2.1 release.

Please refer the below status.

Status of volume: quo
Gluster process                                         Port    Online  Pid
------------------------------------------------------------------------------
Brick 10.16.159.156:/exports/rep                        49153   N       N/A
Brick 10.16.159.182:/exports/rep                        49153   Y       307
Brick 10.16.159.164:/exports/rep                        49153   Y       32539
Brick 10.16.159.134:/exports/rep                        49152   Y       32543
NFS Server on localhost                                 38467   Y       3384
Self-heal Daemon on localhost                           N/A     Y       3396
NFS Server on 10.16.159.134                             38467   Y       752
Self-heal Daemon on 10.16.159.134                       N/A     Y       764
NFS Server on 10.16.159.182                             38467   Y       968
Self-heal Daemon on 10.16.159.182                       N/A     Y       980
NFS Server on 10.16.159.164                             38467   Y       724
Self-heal Daemon on 10.16.159.164                       N/A     Y       737
Comment 5 Krutika Dhananjay 2013-04-16 08:23:15 EDT
Fixed in glusterfs-3.4.0.1rhs1 by the patch http://review.gluster.org/4048.
Hence moving the state of the bug to ON_QA.
Comment 6 Sachidananda Urs 2013-08-01 02:44:28 EDT
Verified on: glusterfs 3.4.0.14rhs built on Jul 30 2013 09:09:36

[root@localhost tmp]# gluster volume status
Status of volume: foo
Gluster process                                         Port    Online  Pid
------------------------------------------------------------------------------
Brick 10.70.37.145:/tmp/foo0/0                          N/A     N       N/A
Brick 10.70.37.145:/tmp/foo1/1                          N/A     N       N/A
NFS Server on localhost                                 2049    Y       3837
Self-heal Daemon on localhost                           N/A     Y       3842
Comment 7 Scott Haines 2013-09-23 18:39:15 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 8 Scott Haines 2013-09-23 18:43:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.