Bug 861552 - There's error log of virt-who after adding a new guest in ESX mode
There's error log of virt-who after adding a new guest in ESX mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 02:31 EDT by lzhuang
Modified: 2016-11-30 19:31 EST (History)
11 users (show)

See Also:
Fixed In Version: virt-who-0.9-1.el5
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: virt-who-0.9-1.el5 Highlights, important fixes, or notable enhancements: The rebase of virt-who adds new virtualization backends that can be used for obtaining host/guest associations. Another improvement is change of permission for the configuration file from world-readable to root-only readable. This change is only for new installations of virt-who. Existing installations should be fixed manually by setting permission of file /etc/sysconfig/virt-who to 600. The rebase also contains various bugfixes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:29:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lzhuang 2012-09-29 02:31:28 EDT
Description of problem:
When the parameter "VIRTWHO_INTERVAL" is smaller than 3 seconds (2s or 1s), and after adding a new guest via Vclient on an ESX host, there will be error log in /var/log/rhsm/rhsm.log. But there's no such log if the interval is set to be lager than 3 seconds (if it's set to be 3 seconds, it's not 100% reproducible).

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.20-1.el5
subscription-manager-1.0.20-1.el5
subscription-manager-firstboot-1.0.20-1.el5
python-rhsm-1.0.9-1.el5
virt-who-0.7-8.el5

How reproducible:
100%

Steps to Reproduce:
1. configure the virt-who with the following parameters and restart service virt-who:
   VIRTWHO_BACKGROUND=1
   VIRTWHO_DEBUG=1
   VIRTWHO_INTERVAL=2
   VIRTWHO_ESX=1
   VIRTWHO_ESX_OWNER=ACME_Corporation
   VIRTWHO_ESX_ENV=env1
   VIRTWHO_ESX_SERVER=10.66.13.216
   VIRTWHO_ESX_USERNAME=<username>
   VIRTWHO_ESX_PASSWORD=<password>

2. Add a new RHEL guest via VClient on ESX host
3. Check the log file /var/log/rhsm/rhsm.log
  
Actual results:
There's error log of virt-who:
   2012-09-29 01:48:29,514 [ERROR]  @virt-who.py:180 - Error in communication with virt backend, trying to recover:
   Traceback (most recent call last):
     File "/usr/share/virt-who/virt-who.py", line 174, in _send
       virtualGuests = self.virt.getHostGuestMapping()
     File "/usr/share/virt-who/vsphere.py", line 230, in getHostGuestMapping
       self.scan()
     File "/usr/share/virt-who/vsphere.py", line 185, in scan
       for propSet in obj.propSet:
   AttributeError: ObjectContent instance has no attribute 'propSet'

Expected results:
There should not be any error log info.

Additional info:
Comment 1 RHEL Product and Program Management 2012-09-29 03:28:07 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 RHEL Product and Program Management 2013-05-01 03:17:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Radek Novacek 2013-08-01 05:59:47 EDT
This bug should be fixed (as well as couple others) in later versions of virt-who. I suggest to do a rebase in rhel-5.11.
Comment 6 Radek Novacek 2014-03-13 09:42:26 EDT
Fixed in virt-who-0.9-1.el5.
Comment 8 Liushihui 2014-04-24 05:24:14 EDT
Verified it on virt-who-0.9-2.el5

Steps to Verify:
1. configure the virt-who with the following parameters and restart service virt-who:
   VIRTWHO_BACKGROUND=1
   VIRTWHO_DEBUG=1
   VIRTWHO_INTERVAL=2
   VIRTWHO_ESX=1
   VIRTWHO_ESX_OWNER=ACME_Corporation
   VIRTWHO_ESX_ENV=Library
   VIRTWHO_ESX_SERVER=10.66.78.16
   VIRTWHO_ESX_USERNAME=Administrator@vsphere.local
   VIRTWHO_ESX_PASSWORD=qwer1234P!
2. Add a new RHEL guest via VClient on ESX host
3. Check the log file /var/log/rhsm/rhsm.log
2014-04-24 04:11:56,569 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [564d1f59-71c6-57c8-62f0-607a7218d24c], 44454c4c-4200-1034-8039-b8c04f503258: []}
2014-04-24 04:12:10,547 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [4200da77-c8af-c013-daef-7c0b7644e016, 564d1f59-71c6-57c8-62f0-607a7218d24c], 44454c4c-4200-1034-8039-b8c04f503258: []}

Result:It hasn't generate error log as the bug description, And it send the correct host/guest to SAM server ,Therefore, verify it on virt-who-0.9-2.el5
Comment 10 errata-xmlrpc 2014-09-15 20:29:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1206.html

Note You need to log in before you can comment on or make changes to this bug.