Bug 861565 - groupadd failed in PREIN scriptlet in 7:squid-3.2.0.16-1.fc17.x86_64
groupadd failed in PREIN scriptlet in 7:squid-3.2.0.16-1.fc17.x86_64
Status: CLOSED DUPLICATE of bug 844167
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 04:05 EDT by Robin Lee
Modified: 2012-10-23 22:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 22:35:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Lee 2012-09-29 04:05:22 EDT
Description of problem:
'yum install squid' failed:
Error in PREIN scriptlet in rpm package 7:squid-3.2.0.16-1.fc17.x86_64
error: %pre(squid-7:3.2.0.16-1.fc17.x86_64) scriptlet failed, exit status 1

If use rpm -Uvh to install squid, it says:
...
groupadd: failure while writing changes to /etc/group
...

Version-Release number of selected component (if applicable):
7:squid-3.2.0.16-1.fc17.x86_64

How reproducible:
yum install squid
Comment 1 Robin Lee 2012-09-29 04:10:00 EDT
Manually run
# groupadd -g 23 squid
is ok.
Comment 2 Tomas Mraz 2012-10-01 03:48:55 EDT
If manually running groupadd is fine, it might be either some other problem in the %pre squid scriptlet or perhaps a SELinux issue.
Comment 3 Michal Luscon 2012-10-18 09:08:19 EDT
Do you have any unusual SELinux settings on your system? I am not experiencing this problem with my f17.
Comment 4 Robin Lee 2012-10-18 21:55:21 EDT
I am not familiar with SELinux. How to find out if I have some unusual settings?

Squid PRE scriptlet seems a bit different since it hard codes the group id.
Comment 5 Robin Lee 2012-10-23 22:35:36 EDT
Tested with selinux-policy-3.10.0-156.fc17

*** This bug has been marked as a duplicate of bug 844167 ***

Note You need to log in before you can comment on or make changes to this bug.