Bug 86159 - ext3 not available in install
ext3 not available in install
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-03-14 21:49 EST by Zenon Panoussis
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-04-22 12:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2003-03-14 21:49:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Disk druid offers ext2 but not ext3 as a file system option. Partitions that are
pre-formatted as ext3 are recognised as such, but then disk druid grays out
their mount point selection box, so they cannot be used unless they are
reformatted to ext2. All in all, it is impossible to install on ext3.

Version-Release number of selected component (if applicable):
whatever is in 8.0.94

How reproducible:

Steps to Reproduce:
1. Create an ext3-formatted partition
2. Start installing (graphical mode)
3. Use disk druid for partitioning
4. Attempt to create a new ext3 partition
5. Attempt to define a mount point for the existing ext3 partition
Comment 1 Michael Fulbright 2003-03-17 14:17:46 EST
If you burned your CDs have you checked them?

ext3 is always available unless there is a problem with the install media.
Comment 2 Zenon Panoussis 2003-03-18 06:44:55 EST
I had to install from a custom-made CD without checksums due to bug #85208. I
attempted an installation on another machine from a standard and checked CD and,
indeed, ext3 is there. This leaves two possibilities: either my custom CD is not
OK, or something specifically on the epia makes anaconda think that ext3 is not

After the no-ext3-available installation I converted my ext2 partitions to ext3.
I did so with the kernel and tools that were installed from the questionable CD
and everything worked fine. This suggests - but does not confirm - that nothing
was wrong with the CD in the first place. The only place left to look in is the
initrd of the CD itself. I haven't done that (but it is at
http://www.provocation.net/bootdisk.img if you want to take a look). 

As things look now, I wouldn't bother investigating this further. Whatever the
problem might be, it will go away anyway when #85208 gets fixed. 
Comment 3 Mike McLean 2003-03-18 09:44:39 EST
When you edit a preexisting partition in disk druid, you have the option of
either preserving data or formatting the partition.  You can select either
option with the radio buttons in the edit dialog, but the default is to preserve
data (i.e. not format).  Unless you select the format option, the partition type
drop down menu will remain disabled since changing the its value would require

I cannot replicate the other problems you have listed.

When you create a *new* partition in disk druid, is ext3 an option or not?

When you edit a *preexisting* (on disk before install began) ext3 partition in
disk druid and select the "format partition as:" radio button, does the
partition type drop down remain greyed out?

In exactly what situation is the mount point entry field disabled?
Comment 4 Zenon Panoussis 2003-03-18 20:15:32 EST
In my case: 
- If you have a pre-existing ext3 partition and you select to preserve the data,
the "select mount point" box is grayed out, making it impossible to use that
partition as part of the system at this stage (what you can do after the
installation is finished is beyond the scope of this bug).
- If you have a pre-existing ext3 partition and you select to re-format it, ext3
is not available as a format option, so you are forced to re-format as ext2. 
- If you create a new partition, ext3 is not available as format option and you
can only format as ext2. 

Thus, all in all, no ext3 is possible either way. 

I wrote earlier "either my custom CD is not OK, or something specifically on the
epia makes anaconda think that ext3 is not available". What I didn't think of
then is that the obvious way to test which of the two it is, it to attempt to
install from my custom CD on a non-epia machine. If ext3 is still not available,
then it's my CD. If ext3 is available, then it's anaconda on the epia. 

I'll do that and report back. You can try it too; the CD image in question is up
for grabs at http://www.provocation.net/epia.html .

Comment 5 Zenon Panoussis 2003-03-19 22:11:01 EST
I tried installing from the same CD on a non-epia machine and ext3 was not
available. It is thus now very safe to assume that something is wrong with my
installation CD. I strongly suggest a NOTABUG on this. 
Comment 6 Michael Fulbright 2003-03-21 11:04:20 EST
How does your custom CD differ fromt the stock RH CD?  I might be able to help
you get it working (although understand this is outside of what Red Hat
officially supports).
Comment 7 Zenon Panoussis 2003-03-23 18:08:30 EST
I copied the entire CD to disk, commented out patch900 in the spec, made kernel
RPMs, installed kernel-BOOT on a machine, moved vmlinux and initrd from there to
the loop-mounted boot image of the CD, moved the i386 and i686 kernels to the
RPMS directory, created a new iso image from the result, burned it and installed
the epia from it. Thus, the difference between the two CDs is vmlinux and initrd
in the boot image, kernels in the RPMS directory, plus the MD5 checksums I lost
in the process.

The kernel that got installed has no problems with ext3. Logically then, the
problem must be in the BOOT kernel that I put in the boot image of the CD.
Perhaps ext3 is excluded in that kernel? Anyway, I guess that all it takes to
fix the CD is to replace the BOOT kernel in its boot image with a normal i386
kernel. The epia works fine by now though, so I haven't tried. 

Thanks for your willingness to help, I appreciate that.
Comment 8 Michael Fulbright 2003-04-02 15:26:19 EST
I would guess that ext3 is not in all the places its needed. There are several
modules.cgz files on the boot initrd and in the stage2.img and you need to
update each with your new modules. These are cpio archives.

Good luck.
Comment 9 Michael Fulbright 2003-04-22 12:30:03 EDT
Closing due to inactivity. If you have new information to add please reopen the
issue report.

Note You need to log in before you can comment on or make changes to this bug.