Bug 861600 - ghostscript update breaks cups filter pstopxl (changed to gstopxl but not updated elsewhere
ghostscript update breaks cups filter pstopxl (changed to gstopxl but not upd...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 08:42 EDT by Michael Setzer II
Modified: 2012-12-20 11:08 EST (History)
2 users (show)

See Also:
Fixed In Version: ghostscript-9.05-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:08:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Setzer II 2012-09-29 08:42:08 EDT
Description of problem:
Todays update of ghostscript causes failure of cups.
Report missing file pstopxl
Fixed by making a symbolic link from gstopxl to pstopxl.

Version-Release number of selected component (if applicable):


How reproducible:
Ran yum update today


Steps to Reproduce:
1. Tried to print via gedit, and it reports that pstopxl is missing from cups filter directory. Did a search, and found new name of gstopxl was there, so made link, and it corrects problem.
2.
3.
  
Actual results:
printing fails due to missing file


Expected results:
with link, it fixes it, so not sure what wasn't updated in the fix.


Additional info:
Comment 1 Simon 2012-10-08 06:10:25 EDT
This is a pain. Took me ages to eventually dig into /var/log/cups/ and find the filter warning. On my F16 desktop, the job just sits in the "system tray" indefinitely...
Comment 2 Tim Waugh 2012-10-10 11:48:28 EDT
Update in the pipeline which adds a pstopxl symlink.
Comment 3 Fedora Update System 2012-10-10 12:09:39 EDT
ghostscript-9.05-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ghostscript-9.05-3.fc16
Comment 4 Fedora Update System 2012-10-10 21:01:02 EDT
Package ghostscript-9.05-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghostscript-9.05-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15864/ghostscript-9.05-3.fc16
then log in and leave karma (feedback).
Comment 5 Michael Setzer II 2012-10-19 14:46:56 EDT
Just ran the yum update and saw that the update has been applied, so issue seems to have been fixed.
Comment 6 Fedora Update System 2012-12-20 11:08:19 EST
ghostscript-9.05-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.