Bug 861602 - Indefinite Yum Lock by PackageKit
Indefinite Yum Lock by PackageKit
Status: CLOSED DUPLICATE of bug 812938
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 08:49 EDT by Adam Joseph Cook
Modified: 2013-02-07 18:35 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-30 10:16:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Joseph Cook 2012-09-29 08:49:58 EDT
Description of problem:
A yum lock is established at startup which is never (apparently) released by PackageKit which never frees the lock. PackageKit is running in the background. Requests (or waits) for the lock to be freed on user-facing apps (System Update GUI, Software GUI and yum cmd line) indefinitely wait for the lock to be freed.

Killing the 'packagekitd' process manually seems to be a workaround.

Version-Release number of selected component (if applicable):
yum-presto-0.9.0-1.fc18.noarch
anaconda-yum-plugins-1.0-8.fc18.noarch
PackageKit-yum-0.8.3-3.fc18.x86_64
yum-3.4.3-44.fc18.noarch
yum-langpacks-0.3.0-3.fc18.noarch
yum-metadata-parser-1.1.4-7.fc18.x86_64
PackageKit-yum-plugin-0.8.3-3.fc18.x86_64
yum-utils-1.1.31-6.fc18.noarch
eclipse-packagekit-0.0.2-4.fc18.x86_64
gnome-packagekit-3.5.90-1.fc18.x86_64

How reproducible:
Startup system and run 'yum update' (or similar) from the command line.

Steps to Reproduce:
1. Login to desktop.
2. Attempt to run 'yum update' (or similar) from the command line.
3. App waits indefinetly for yum lock to be released.
  
Actual results:
* Output of yum update:

Loaded plugins: langpacks, presto, refresh-packagekit
Existing lock /var/run/yum.pid: another copy is running as pid 1657.
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: PackageKit
    Memory :  49 M RSS (355 MB VSZ)
    Started: Sat Sep 29 07:07:01 2012 - 23:01 ago
    State  : Sleeping, pid: 1657
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: PackageKit
    Memory :  49 M RSS (355 MB VSZ)
    Started: Sat Sep 29 07:07:01 2012 - 23:03 ago
    State  : Sleeping, pid: 1657
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: PackageKit
    Memory :  49 M RSS (355 MB VSZ)
    Started: Sat Sep 29 07:07:01 2012 - 23:05 ago
    State  : Sleeping, pid: 1657
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: PackageKit
    Memory :  49 M RSS (355 MB VSZ)
    Started: Sat Sep 29 07:07:01 2012 - 23:07 ago
    State  : Sleeping, pid: 1657
^C

Exiting on user cancel.

* Result of running ps aux | grep packagekitd:

ps aux | grep packagekitd
root      1331  0.2  0.1 319772  5592 ?        Sl   07:06   0:04 /usr/libexec/packagekitd
root      2586  0.0  0.0   6816   812 pts/0    S+   07:33   0:00 grep --color=auto packagekitd

* Killing process 1331 allows 'yum update' to proceed.
 
Expected results:
Packagekitd should not need to be killed manually to proceed with system updated and software installs via yum.

Additional info:

Possibly similar to:

https://bugzilla.redhat.com/show_bug.cgi?id=810530
https://bugzilla.redhat.com/show_bug.cgi?id=812938
Comment 1 Adam Joseph Cook 2012-09-29 09:02:05 EDT
Latest system update (performed just now) and a reboot did not fix this issue.
Comment 2 Elad Alfassa 2012-09-30 10:16:47 EDT
I'm going to go ahead and close this as a duplicate of bug #812938.




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 812938 ***
Comment 3 Adam Joseph Cook 2012-09-30 10:49:01 EDT
Thanks for the information and the patch, Elad. I will apply it today and give feedback.

Note You need to log in before you can comment on or make changes to this bug.