Bug 861641 - Kernel missing ufs driver; can't mount FreeBSD partitions
Kernel missing ufs driver; can't mount FreeBSD partitions
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 12:16 EDT by matt
Modified: 2012-09-29 14:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-29 14:32:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matt 2012-09-29 12:16:56 EDT
Description of problem:
Cannot mount UFS filesystems due to lack of ufs kernel module.   The mount manpage claims to still support ufs, however there is no ufs.ko in any of the kernels.


Version-Release number of selected component (if applicable):
3.5.4-1.fc17.x86_64
3.5.3-1.fc17.x86_64
3.5.2-3.fc17.x86_64


How reproducible:
Install Fedora 17.  Try to mount FreeBSD or other UFS partition.


Steps to Reproduce:
1.  mount -tufs -o ufstype=ufs2,ro /dev/sdg1 /mnt/test1
2.
3.
  
Actual results:
Error message:
mount: unknown filesystem type 'ufs'

Expected results:
Successful mount

Additional info:
# modprobe ufs
FATAL: Module ufs not found.


# ls -l /lib/modules/*/kernel/fs/ufs
/lib/modules/3.5.2-3.fc17.x86_64/kernel/fs/ufs:
total 0

/lib/modules/3.5.3-1.fc17.x86_64/kernel/fs/ufs:
total 0

/lib/modules/3.5.4-1.fc17.x86_64/kernel/fs/ufs:
total 0
Comment 1 Josh Boyer 2012-09-29 14:32:06 EDT
It's in the kernel-modules-extra subpackage.  Install that.

Note You need to log in before you can comment on or make changes to this bug.