This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 861698 - /lib64/libQtGui.so.4 is truncated
/lib64/libQtGui.so.4 is truncated
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-30 00:44 EDT by Lee Marshall
Modified: 2012-09-30 12:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-30 12:31:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lee Marshall 2012-09-30 00:44:17 EDT
Description of problem:
Since Upgrade to qt-x11.i686 1:4.8.2-4.fc17 3 applications that utilize Qt have stopped working - all terminate immediately with segfault

Version-Release number of selected component (if applicable):

3 apps that appear to be effected are: 
VLC
Stellarium
VirtualBox


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I appears that the library that is at fault is /lib64/libQtGui.so.4
Yum just happens to report the following errors during install:
# yum install qt-x11.i686
/sbin/ldconfig: file /lib64/libQtGui.so.4.8 is truncated
/sbin/ldconfig: file /lib64/libQtGui.so.4 is truncated
/sbin/ldconfig: file /lib64/libQtGui.so.4.8.2 is truncated

Suspect that could be the root cause.
Comment 1 Kevin Kofler 2012-09-30 10:34:18 EDT
Did you run out of disk space?
Comment 2 Lee Marshall 2012-09-30 12:20:59 EDT
(In reply to comment #1)
> Did you run out of disk space?

Not even close...
Comment 3 Lee Marshall 2012-09-30 12:25:53 EDT
Further investigations to reproduce the Yum error are underway.  However,
somehow, the i686 package was getting installed, NOT the x86_64 package.

A manual reinstall of the proper qt-X11.x86_64 package does appear to solve the problem.  If I can recreate the issue I'll update...

Note You need to log in before you can comment on or make changes to this bug.