Bug 861754 - libqzeitgeist depends on zeitgeist
Summary: libqzeitgeist depends on zeitgeist
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libqzeitgeist
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 861715
Blocks: depchain 838520
TreeView+ depends on / blocked
 
Reported: 2012-09-30 13:44 UTC by Christoph Wickert
Modified: 2012-11-03 15:59 UTC (History)
8 users (show)

Fixed In Version: libqzeitgeist-0.8.0-8.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of: 861715
Environment:
Last Closed: 2012-11-03 15:59:37 UTC


Attachments (Terms of Use)

Description Christoph Wickert 2012-09-30 13:44:47 UTC
+++ This bug was initially created as a clone of Bug #861715 +++

Description of problem:
libqzeitgeist should not depend on the zeitgeist-deamon. A client side library that many applications link against should not require a daemon. Whether or not the user wants to install and use zeitgeist is a completely different story than installing a library.

Version-Release number of selected component (if applicable):
zeitgeist-0.9.0-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. try to remove zeitgeist
  
Actual results:
# LANG=C yum remove zeitgeist
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package zeitgeist.x86_64 0:0.9.0-1.fc17 will be erased
--> Processing Dependency: zeitgeist for package: libqzeitgeist-0.8.0-6.fc17.x86_64
--> Processing Dependency: zeitgeist for package: libzeitgeist-0.3.18-1.fc17.x86_64
--> Running transaction check
---> Package libqzeitgeist.x86_64 0:0.8.0-6.fc17 will be erased
--> Processing Dependency: libqzeitgeist.so.1()(64bit) for package: phonon-4.6.0-3.fc17.x86_64
---> Package libzeitgeist.x86_64 0:0.3.18-1.fc17 will be erased
--> Processing Dependency: libzeitgeist-1.0.so.1()(64bit) for package: zeitgeist-datahub-0.7.0-4.fc17.x86_64
--> Running transaction check
---> Package phonon.x86_64 0:4.6.0-3.fc17 will be erased
--> Processing Dependency: libphonon.so.4()(64bit) for package: 2:phonon-backend-gstreamer-4.6.2-1.fc17.x86_64
--> Processing Dependency: libphonon.so.4()(64bit) for package: 1:kdepim-runtime-4.9.1-1.fc17.x86_64
--> Processing Dependency: libphonon.so.4()(64bit) for package: 7:kdepim-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libphonon.so.4()(64bit) for package: 7:kdepim-4.9.1-1.fc17.x86_64
--> Processing Dependency: libphonon.so.4()(64bit) for package: PyQt4-4.9.1-2.fc17.x86_64
--> Processing Dependency: libphonon.so.4()(64bit) for package: kdepimlibs-akonadi-4.9.1-3.fc17.x86_64
--> Processing Dependency: libphonon.so.4()(64bit) for package: kde-runtime-4.9.1-1.fc17.x86_64
--> Processing Dependency: libphonon.so.4()(64bit) for package: 6:kdelibs-4.9.1-4.fc17.x86_64
--> Processing Dependency: libphonon.so.4()(64bit) for package: kde-runtime-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: phonon(x86-64) >= 4.6.0 for package: 2:phonon-backend-gstreamer-4.6.2-1.fc17.x86_64
--> Processing Dependency: phonon(x86-64) >= 4.6.0 for package: 6:kdelibs-4.9.1-4.fc17.x86_64
---> Package zeitgeist-datahub.x86_64 0:0.7.0-4.fc17 will be erased
--> Running transaction check
---> Package PyQt4.x86_64 0:4.9.1-2.fc17 will be erased
--> Processing Dependency: PyQt4 for package: liveusb-creator-3.11.7-1.fc17.noarch
---> Package kde-runtime.x86_64 0:4.9.1-1.fc17 will be erased
--> Processing Dependency: kde-runtime = 4.9.1-1.fc17 for package: kde-runtime-flags-4.9.1-1.fc17.noarch
--> Processing Dependency: kde-runtime >= 4.9.1 for package: kwallet-4.9.1-1.fc17.x86_64
---> Package kde-runtime-libs.x86_64 0:4.9.1-1.fc17 will be erased
---> Package kdelibs.x86_64 6:4.9.1-4.fc17 will be erased
--> Processing Dependency: kdelibs4(x86-64) >= 4.9.1 for package: nepomuk-core-4.9.1-1.fc17.x86_64
--> Processing Dependency: kdelibs4(x86-64) >= 4.9.1 for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: kdelibs4(x86-64) >= 4.9.1 for package: kactivities-4.9.1-1.fc17.x86_64
--> Processing Dependency: kdelibs4(x86-64) >= 4.9.1 for package: nepomuk-core-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkcmutils.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkcmutils.so.4()(64bit) for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: libkdeclarative.so.5()(64bit) for package: kactivities-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdecore.so.5()(64bit) for package: 1:kdepim-runtime-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdecore.so.5()(64bit) for package: nepomuk-core-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdecore.so.5()(64bit) for package: libkolab-0.3.1-3.fc17.x86_64
--> Processing Dependency: libkdecore.so.5()(64bit) for package: kactivities-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdecore.so.5()(64bit) for package: nepomuk-core-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdecore.so.5()(64bit) for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: libkdecore.so.5()(64bit) for package: libkgapi-0.4.2-1.fc17.x86_64
--> Processing Dependency: libkdecore.so.5()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdeui.so.5()(64bit) for package: 1:kdepim-runtime-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdeui.so.5()(64bit) for package: nepomuk-core-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdeui.so.5()(64bit) for package: libkolab-0.3.1-3.fc17.x86_64
--> Processing Dependency: libkdeui.so.5()(64bit) for package: kactivities-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdeui.so.5()(64bit) for package: nepomuk-core-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdeui.so.5()(64bit) for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: libkdeui.so.5()(64bit) for package: libkgapi-0.4.2-1.fc17.x86_64
--> Processing Dependency: libkdeui.so.5()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkdewebkit.so.5()(64bit) for package: libkgapi-0.4.2-1.fc17.x86_64
--> Processing Dependency: libkemoticons.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkemoticons.so.4()(64bit) for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: libkidletime.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkidletime.so.4()(64bit) for package: nepomuk-core-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkio.so.5()(64bit) for package: 1:kdepim-runtime-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkio.so.5()(64bit) for package: nepomuk-core-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkio.so.5()(64bit) for package: libkolab-0.3.1-3.fc17.x86_64
--> Processing Dependency: libkio.so.5()(64bit) for package: kactivities-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkio.so.5()(64bit) for package: nepomuk-core-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkio.so.5()(64bit) for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: libkio.so.5()(64bit) for package: libkgapi-0.4.2-1.fc17.x86_64
--> Processing Dependency: libkio.so.5()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkparts.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkparts.so.4()(64bit) for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: libkparts.so.4()(64bit) for package: libkgapi-0.4.2-1.fc17.x86_64
--> Processing Dependency: libkprintutils.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libktexteditor.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libkutils.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libnepomuk.so.4()(64bit) for package: 1:kdepim-runtime-libs-4.9.1-1.fc17.x86_64
--> Processing Dependency: libnepomuk.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libnepomuk.so.4()(64bit) for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: libnepomuk.so.4()(64bit) for package: kactivities-4.9.1-1.fc17.x86_64
--> Processing Dependency: libnepomuk.so.4()(64bit) for package: libkgapi-0.4.2-1.fc17.x86_64
--> Processing Dependency: libnepomukquery.so.4()(64bit) for package: kactivities-4.9.1-1.fc17.x86_64
--> Processing Dependency: libnepomukutils.so.4()(64bit) for package: kate-part-4.9.1-1.fc17.x86_64
--> Processing Dependency: libnepomukutils.so.4()(64bit) for package: kdepimlibs-4.9.1-3.fc17.x86_64
--> Processing Dependency: libnepomukutils.so.4()(64bit) for package: libkgapi-0.4.2-1.fc17.x86_64
--> Processing Dependency: libplasma.so.3()(64bit) for package: kactivities-4.9.1-1.fc17.x86_64
--> Processing Dependency: libsolid.so.4()(64bit) for package: nepomuk-core-libs-4.9.1-1.fc17.x86_64
---> Package kdepim.x86_64 7:4.9.1-1.fc17 will be erased
---> Package kdepim-libs.x86_64 7:4.9.1-1.fc17 will be erased
---> Package kdepim-runtime.x86_64 1:4.9.1-1.fc17 will be erased
---> Package kdepimlibs-akonadi.x86_64 0:4.9.1-3.fc17 will be erased
---> Package phonon-backend-gstreamer.x86_64 2:4.6.2-1.fc17 will be erased
--> Running transaction check
---> Package kactivities.x86_64 0:4.9.1-1.fc17 will be erased
---> Package kate-part.x86_64 0:4.9.1-1.fc17 will be erased
---> Package kde-runtime-flags.noarch 0:4.9.1-1.fc17 will be erased
---> Package kdepim-runtime-libs.x86_64 1:4.9.1-1.fc17 will be erased
---> Package kdepimlibs.x86_64 0:4.9.1-3.fc17 will be erased
---> Package kwallet.x86_64 0:4.9.1-1.fc17 will be erased
---> Package libkgapi.x86_64 0:0.4.2-1.fc17 will be erased
---> Package libkolab.x86_64 0:0.3.1-3.fc17 will be erased
---> Package liveusb-creator.noarch 0:3.11.7-1.fc17 will be erased
---> Package nepomuk-core.x86_64 0:4.9.1-1.fc17 will be erased
---> Package nepomuk-core-libs.x86_64 0:4.9.1-1.fc17 will be erased
--> Finished Dependency Resolution

Having livecd-creator depend on zeitgeist because PyQt4 is compiled against libqzeitgeist is just ridiculous as it offers absolutely no benefit.
This is just one example of many, another one is in bug 838520.


Additional info:
This problem was already mentioned in the libzeitgeist review, but nobody seemed to care: https://bugzilla.redhat.com/show_bug.cgi?id=674188#c2

Comment 1 Fedora Update System 2012-10-03 17:32:06 UTC
libqzeitgeist-0.8.0-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libqzeitgeist-0.8.0-8.fc18

Comment 2 Fedora Update System 2012-10-03 17:32:52 UTC
libqzeitgeist-0.8.0-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libqzeitgeist-0.8.0-8.fc17

Comment 3 Fedora Update System 2012-10-04 00:04:56 UTC
Package libqzeitgeist-0.8.0-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libqzeitgeist-0.8.0-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15337/libqzeitgeist-0.8.0-8.fc17
then log in and leave karma (feedback).

Comment 4 Christoph Wickert 2012-11-03 15:59:37 UTC
libqzeitgeist-0.8.0-8.fc17 is in stable, closing.


Note You need to log in before you can comment on or make changes to this bug.