Bug 861799 - get-iana.sh script out of date
get-iana.sh script out of date
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: firehol (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-30 16:26 EDT by Michael Ekstrand
Modified: 2012-12-20 11:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:15:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Ekstrand 2012-09-30 16:26:31 EDT
Description of problem:
The get-iana.sh script seems to be out of date; it cannot fetch the current port reservation map.

Version-Release number of selected component (if applicable):
1.273-5

How reproducible:
Always.

Steps to Reproduce:
1. Run /usr/libexec/firehol/get-iana.sh
  
Actual results:
Fetching IANA IPv4 Address Space, from:
http://www.iana.org/assignments/ipv4-address-space

--2012-09-30 15:25:37--  http://www.iana.org/assignments/ipv4-address-space
Resolving www.iana.org... 192.0.32.8, 2620:0:2d0:200::8
Connecting to www.iana.org|192.0.32.8|:80... connected.
HTTP request sent, awaiting response... 302 FOUND
Location: http://www.iana.org/assignments/ipv4-address-space/ipv4-address-space.xml [following]
--2012-09-30 15:25:38--  http://www.iana.org/assignments/ipv4-address-space/ipv4-address-space.xml
Connecting to www.iana.org|192.0.32.8|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 49862 (49K) [text/xml]
Saving to: “STDOUT”

100%[=========================================>] 49,862      99.2K/s   in 0.5s    

2012-09-30 15:25:39 (99.2 KB/s) - written to stdout [49862/49862]



FOUND THE FOLLOWING RESERVED IP RANGES:
RESERVED_IPS=""


Failed to find reserved IPs.
Possibly the file format has been changed, or I cannot fetch the URL.


Expected results:
Download IANA files.

Additional info:
The plain-text address data seems to be moved here: http://www.iana.org/assignments/ipv4-address-space/ipv4-address-space.txt

However, if I just update the script to fetch that data, it still cannot correctly parse it.
Comment 1 Fedora Update System 2012-10-02 16:36:49 EDT
firehol-1.273-10.1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/firehol-1.273-10.1.el6
Comment 2 Fedora Update System 2012-10-02 16:37:00 EDT
firehol-1.273-10.1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/firehol-1.273-10.1.fc18
Comment 3 Fedora Update System 2012-10-02 16:37:10 EDT
firehol-1.273-10.1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/firehol-1.273-10.1.fc16
Comment 4 Fedora Update System 2012-10-02 16:37:21 EDT
firehol-1.273-10.1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/firehol-1.273-10.1.el5
Comment 5 Fedora Update System 2012-10-02 16:37:32 EDT
firehol-1.273-10.1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/firehol-1.273-10.1.fc17
Comment 6 Fedora Update System 2012-10-02 23:22:22 EDT
Package firehol-1.273-10.1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firehol-1.273-10.1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15260/firehol-1.273-10.1.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 11:15:54 EST
firehol-1.273-10.1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.