Bug 861852 - jgoodies-forms-1_6_0 is available
jgoodies-forms-1_6_0 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jgoodies-forms (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed El Morabity
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On: 861851
Blocks: 887851
  Show dependency treegraph
 
Reported: 2012-10-01 03:26 EDT by Upstream Release Monitoring
Modified: 2013-01-29 11:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 11:06:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec-file patch to update to latest version (1.63 KB, patch)
2012-12-17 08:19 EST, Mary Ellen Foster
no flags Details | Diff
Updated pom.xml patch (672 bytes, patch)
2012-12-17 08:20 EST, Mary Ellen Foster
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2012-10-01 03:26:18 EDT
Latest upstream release: 1_6_0
Current version in Fedora Rawhide: 1.5.1
URL: http://www.jgoodies.com/downloads/libraries/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Mary Ellen Foster 2012-12-17 08:19:20 EST
Created attachment 664846 [details]
Spec-file patch to update to latest version

Here's a patch -- not many changes required, just an update to the requirements and a rebased patch
Comment 2 Mary Ellen Foster 2012-12-17 08:20:28 EST
Created attachment 664847 [details]
Updated pom.xml patch
Comment 3 Mary Ellen Foster 2012-12-19 11:23:17 EST
Note that there are a few incompatible changes from 1.5 to 1.6 which could break packages using jgoodies-forms. Here's the full list of packages that require jgoodies-forms:
% repoquery --whatrequires --recursive jgoodies-forms
antlrworks-0:1.4.3-6.fc18.noarch
freemind-0:0.9.0-11.fc18.noarch
freemind-javadoc-0:0.9.0-11.fc18.noarch
icegrid-gui-0:3.4.2-18.fc18.x86_64
jabref-0:2.8-4.fc18.noarch


I'd actually like to push new versions of jabref and icegrid-gui (which both require jgoodies-forms 1.6.0); freemind doesn't seem to have a problem with the new jgoodies-forms; and I have a small patch prepared for antlrworks.

I'm a former maintainer of this package and have provenpackager access. If you're willing, I'm prepared to push updates to the following packages:
- jgoodies-common
- jgoodies-forms
- antlrworks
Comment 4 Mohamed El Morabity 2012-12-30 21:00:20 EST
Many thanks for your great work! As you mentionned above, antlrworks is indeed the only package which would need some work to work with the latest version of jgoodies-forms.
Since I maintain antlrworks too, I'd be very happy if you could provide here the patch for antlrworks. Once I get it, I will update all the jgoodies-* packages, as well as antlrworks.

Note You need to log in before you can comment on or make changes to this bug.